How to use PTex in Maya 2013


#21

I had to change the \ to / in the file path names. also the rayrc file must be edited as indicated if you didnt do that

Tried the forward slash as well. I downloaded the bunny example just to see if my PTEX file might be done wrong. I think there might be other technical subtleties that haven’t been mentioned yet. I’m simply trying to plug the mib_ptex_lookup into the color slot for the moment and get that to work before I even think about vector displacement or other more advanced stuff. Baby steps.

I’ve looked at the scarce info on MentalRay and PTex and found this http://forum.mentalimages.com/showthread.php?3980-maya-rayrc-location and this one from another thread http://forum.mentalimages.com/showthread.php?9506-bump-maps-with-mib_ptex_lookup-in-maya-2013 but again, that didn’t fix the problem.

I believe that this new way of texturing will gain great advances eventually and will be simplified as time goes by. For now, I’ll make way for the TDs to solve these issues that are way over my head.


#22

When modifying the .rayrc file, where does the registry “{_MI_REG_CCMESH_PTEX}” value “on” end registry line go? Maybe I haven’t pasted it in the right area. Every line in the code has the # symbol in front of them. Does that need to be added or pasted as is? Sorry for the lack of programming vernacular. I’m just trying to get my Mari/Mudbox texture to be rendered in Maya 2013. Thanks.


#23

I have been using a mib_color_intesity node to pass the mib_ptex_lookup into the mental ray displacement shader of a MIA X material. So far it works fine for regular displacement, but when I use Vector Displacement ptex files from Mudbox, I get lots of seams in my render(Maya 2013, mental ray).

Any ideas on how to get rid of these seams?


#24

In the Maya.rayrc file. Remove the # in front of the added registry line for ptex or it won’t activate it.


#25

Glad you got it sorted, the # denotes its non executable text for annotating script


#26

Has anybody been able to get a ptex vector displacement map to work in Maya? Regular displacement works like a charm, but haven’t been able figure out the right node for MR in Maya. Tried the mib_data_get_shader_vector node but that doesn’t change anything. I guess there needs be a custom node created for that?


#27

Can you post a mesh and ptex vector displacement map? I think I know how this could be done but I need some example files to work with.


#28

Been able to get vector displacement with this guy’s http://joomla.renderwiki.com/joomla/index.php?option=com_content&view=article&id=331&Itemid=229 shader. Plug the mib_ptex_lookup into the “normal” slot in his vectorDisplace node and then into the shadergroup displacement shader. No seams or artifacts. Ptex rules!

Make sure that when you do a VDM extraction in Mudbox, that you use “object” in the Vector Displacement Map Options.


#29

Would be nice to get tangent space working though. Can someone post a obj and ptex tangent space vdm to test out?


#30

Did anyone get this to you? If not I can make a test object/vdm for you. Would be great to get it working.

-NB


#31

If you could make a test object, that would be great!


#32

Here is a simple head with an ear on it’s forehead made in and exported from Mudbox to test with:

HeadBaseTest.fbx

Here is a Maya 2013 scene setup with the head:

PtexVectorDispExample.ma

and here is the Ptex VDM file:
headTest.ptx

Hope these are helpful.


#33

Aha! Beat me to it. Look forward to seeing what you find out. Good luck,

-Nick


#34

Thanks, this is a tangent space map, correct?


#35

Yes, the map was extracted in Mudbox as a tangent space VDM .ptx

Please let me know if you need anything else for your testing. In related news I have heard back from the Mental Images guys on why the VDMs crash the standard Maya displacement shader:

"Thanks a lot for the file! The crash happens because the maya shaders mess with state->type.

The good news however is that we could provide a workaround in the ptex shaders. We’ll send more
information when the update is available for download."


#36

Ah well, no point me testing if that’s the case, may as well wait for the fix from nvidia.


#37

If you want to follow that thread from nVidia:

http://forum.mentalimages.com/showthread.php?9560-Ptex-vector-displacement-in-Maya2013&p=38881#post38881


#38

Updated Ptex shaders: http://forum.mentalimages.com/showthread.php?9678-ptex-shader-update-available-for-download&p=38936#post38936


#39

Hello,

I’m having sort of a strange issue.

I went through all the steps in this tutorial, and it worked…for one object and one shader. Every other time I’ve tried to plug in the mib_ptex_lookup, I’ve gotten a permission denied message and the model renders black. I can still use that one working mib_ptex_lookup for other ptex files, so I know it’s not the ptex file itself.

Does anyone have any ideas on why this is happening?


#40

bump…

I am curious about this too.

Also does anyone know if the updated ptex shader is included in the recent versions of Maya 2013? Or do you have to download it still?