How to make object not block FG rays?


#1

The green sphere on the example image is the only thing in the scene emitting light with FG rays, and the cube beneath it is blocking some of the light from hitting the floor.

  • How can I make that object so it does not “block FG rays” ?

The settings on the Shape node under Render Stats and Mental Ray does not help to uncheck.


#2

Did you checked out the settings on the “Transform” node (I know that suck) ? Maybe some stuff in the Trace options will work for you.


#3

no, those settings don’t change anything, but thx for the reply :slight_smile:


#4

You wanna this object to still get Final Gather Illumination? I don’t think it’s possible to make it in one shot, I hardly see an object being able to catch illumination and don’t obscure it at same time. A possible way is to generate your Final Gather Map with the object hidden, and put the rebuild on Off, you should get your effect like this.


#5

got it to work with p_ray_state combined with mib_continue


#6

nice. i was looking for a solution long time ago,too
could you post a little demo scene where we could take a look ?

would be great !

greets,
max


#7

will post it tomorrow at work


#8

oh gratz on this one :]


#9

Link to test scene (Maya 8.5 x64): http://clip2net.com/page/m7266/297071

You need to download Puppet shader pack from here: http://www.puppet.tfdv.com/download/shaders_p_e.shtml

And this is the Shader network if you wan’t to get it to work whitout the test scene:
(Add p_ray_type as youre shader on youre object in the scene, and then plug in the actual visual shader into the “Eye” slot, press “Enable Finalgather” and plugin the mib_continue into the Finalgather slot, this will take the incomming FG rays hitting the object and then send them further onto another node, there are many other uses for this setup aswell)


#10

thx alot… i will give it a try as soon as i am home again.


#11

Great that someone finally came up with a solution for this problem, but I´d like to find a solution which doesn´t require the installation of any aditional shaders. In my case the blocking objects don´t even need to catch final gather, but I can´t hide them … any ideas?


#12

Use mip_rayswitch


#13

Thanks for your reply!
Yes, I´m already using mip_rayswitch in Maya 2008 … but I want this to work in Maya 8.5, too. :slight_smile:


#14

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.