How to brighten up frosted glass product scene


#1

Hi there,
I’m creating a product shot scene (based on photography I’m trying to mimic), some products are made of clear glass, others frosted. My problem occurs in both materials but is worse in the frosted one.

I’ve been struggling many hours trying to figure out how I can brighten up the glass. (I’ve attached a stripped down version plus a partial screen grab of the reference product photo)

I’d like it to appear closer to white instead of grey, and still have the content shine through.
Especially the product on the left in the reference image is what I’m going for.

For example adding luminance to the material will brighten the material, but also ‘hide’ or ‘fade’ the content.
From what I found on the web, I’ve tried altering the light settings, materials, render settings, and adding objects to reflect in the glass.

Maybe I’m missing something, or it’s actually behaving as expected and I’m trying to achieve an unnatural effect?
I do realize in the reference photo the glass isn’t white either, it’s much brighter and I’m aiming for an even brighter/fresher look overall.

Any help greatly appreciated! :slight_smile:
Thanks so much!

Edit: FYI I’m on R19 Studio

Stripped_frosted_glass_scene.c4d (886.4 KB)
06%20PM


#2

So,
tweaking the material’s reflectance channel slightly,
and a few adjustments in the render settings (options) helped a little.

Attached former and current render preview, updated file and screen grab of the render settings.

Also wondering what’s causing the dark ‘outline’ around the products, especially on the left side?
Could this have anything to do with ray depth? It looks like a dark fresnel.

Thanks,
UPStripped_frosted_glass_scene_ro1.c4d (318.0 KB)


#3

Hi, I took a look at your file - but there’s some unusual stuff in there. I’d strip it all back if I were you.

•Get rid of all the extra passes and ambient occlusion/glow/caustics. It’s overcomplicating it.
•Make sure the lights have reflections turned on (at the minute they’re off and the left and right lights are directly on top of each other.)
•Make sure your liquid intersects the glass - it shouldn’t sit inside it.
•Add a Light mapping as second bounce in GI
•In the options section of your render settings, the numbers are all odd. Reset everything. Make sure ray depth in particular is over 15.

You still will need to manage the placement of your lights better - but this is enough for starters :wink:


#4

Hi Davetwo,
thanks so much for your feedback!

I’m sure I tinkered around so much there’s likely a bunch of redundant settings going on.

I’ll go have a look and see how things turn out!
Thanks again!
UP


#5

OK, great, this is certainly helping me to both find clarity in my head AND scene :slightly_smiling_face:
There’s definitely improvement in some areas.

The odd render options settings were the result of trying to reduce render times, which helped a lot.
Now they’re very slow unfortunately.

The glass however still renders very dark, I’m still puzzled where to look to brighten it up.
(In my previous scene, R01, the glass came out brighter, which is my goal)

And about light placement, I’m wondering what you’d suggest to do differently?
I’m actually coming from a photography background, and thinking from that perspective they’re positioned quite OK as is.

See progress screen grabs: R00 > R01 > R02
(Where R01 is closer to what I’m looking for)
Edit: attached order is messed up, from left to right: R01 / R00 / R02

Thanks again!

R01R00R02

Stripped_frosted_glass_scene_ro2.c4d (320.2 KB)

(Attached revised scene)