How to bake a Light Objects Illumination INTO a texture map


#1

Hi peeps.

Bit of a head scratcher here… I’m modelling a Fantasy Leaf.
This is what it looks like under default lighting…
https://www.dropbox.com/s/4b1lni1ikmsp5ae/Leaf%201.jpg?dl=0

I then went ahead and created quite a lot of Light Objects close to the leaf. (Here’s an image of what this looks like in the preview window)
https://www.dropbox.com/s/lhnktpwo2h1vlvr/Leaf%202.jpg?dl=0

So when I render the image with these lights activated… THIS is what the Leaf looks like…
https://www.dropbox.com/s/eqt5ppmq54tq2ky/Leaf%203.jpg?dl=0

See how the light objects give (to my mind) a really nice illumination of bright colours spilling onto the leaf. This Leaf is part of a Fantasy world, so I want it to have a sort of ‘bio-luminescense’ vibe to it.

So what I would like to achieve is… Because I’m using a TON of Light Objects to light this individual leaf (and in the final scene, there’ll be about 50 of these leaves)… To cut down on render times (of C4D having to calculate the ‘light spill’ every time)… I’d like to BAKE the effects of this ‘light spill’ out as a texture map, and have it applied to the Luminence channel.
Ultimately making it so the leaf looks EXACTLY like the image above, but without the need of the many light objects in the scene.

So yeah… How do I do this?

I assumed the folloiwing would work…
1 - Apply ‘Bake Texture Tag’ to the Leaf Object.
2 - Bake out ‘Illumination’.
3 - Turn off the lights in the scene and instead apply the newly baked ‘Illumination texture’ (which was made in step 2) to the Luminance channel.

I thought that should work… But it has not.
Baking out ‘Illumination’ gives a wierd ‘green’ result (and applying it to the Luminance channel looks NOTHING like how it should)
https://www.dropbox.com/s/dx8ne45fv5ow3cg/Luna_Leaf_3_Illumination.png?dl=0

So yeah, can anyone figure out how to achieve something like this?

You can download my scene file here and see for yourself.
https://www.dropbox.com/s/rctnadzqgsti2n9/ASSET%20-%20Luna%20Leaf%201.c4d?dl=0

Thanks!


#2

try baking the ‘surface colour’ option.
That should be everything including the lighting as you see it in the render.


#3

Hi man.
Thanks for the response.
Unfortunately however, it’s still not working.

It doesn;t seem like ANY options in the ‘Bake Texture’ tag produce an image which retains the light colours as they appear in the original render.
Take a look at the image here…

(EDIT… Am I being dumb? Or is this forum unable to embed image files into a post? If you cannot see a picture above this sentance, and instead see some garbled ‘codey’ text… Please click on THIS link to see the image that you’re supposed to see :slight_smile: )
https://www.dropbox.com/s/nisjib5ardf3b90/Leaf%204.jpg?dl=0

COLOR - It’s just rendering out a texture version of the procedural material I made for the leafs surface, and NOT including any of the light data…
LUMINANCE - I dunno WHAT’S going on with Luminance… It just renders out a black texture file…
SURFACE COLOR - Basically the same as ‘Color’… Still not taking the colours from the light objects into account…
ILLUMINATION - Gives this wierd green result :S

I am ABSOLUTELY stumped with this one… Surely there must be a way to bake an image file out of the original object + lights so it looks JUST like how it does in the original render?


#4

Just a thought … as to how I’d tackle this …
Looks like a bend deformer was used, so, I’d uncheck it so I get a flat leaf,
adjust lights to suit … render out to use as a texture … check the bend
deformer back on … put it in a cloner and away you should go.


#5

Totally INVERTED normals … FIX them and bake Surface Color again… :slight_smile: