Hi Res textures => optimise render time



I have hi res Earth texture map :
color = 8k x 4k (8192 x 4096 pixels)
bump = 8k x 4k
cloud = 8k x 4k

A sphere to make earth surface, and a sphere around to place cloud with transparency.
I render that with 1 distant light and a ramp texture to have a little backlight or fresnel.
In the animation, the camera approach the Earth to see countries.

Questions :

1 - Is there any custom presets to optimise the scene (display and render) ?
2 - Is there a prefered image format ? (tiff / tga / iff / jpg) ?
3 - on the attribute editor, in the “file” page, filter type, pre filter, prefilter radius, use BOT, disable file load… What do they mean ?

Thank you :slight_smile:


Hi Shiver,

For such a high-res map if you’re rendering it with mentalray you may need to convert your files to a map format.

Open a command prompt and type:
imf_copy -pvr “path/…/sourceimages/file.jpg” “path/…/sourceimages/file.map”
This way the map doesn’t eat your memory anymore.

In general my favourite file format is iff. ( maya’s native )

mipmap filter
elliptical filter
You might need a better filtering than the standarts as you fly close to the surface looking at the skyline. So please try the elliptical and follow the advice of FLOZE+ at this link


thanks a lot rollmops,
i tried this night the .tga >.map files with imf_copy.
so i replaced tga textures with .map and rendered.
But… i have little pb with my textures when i render them.

Else there is the good picture:
8k x 4k TGA Textures / Render OK
Mental Ray / Render time : 3’50"

Take a look :
The render time of this image is about 3’50", I think it’s not too bad.
Production Quality / Raytracing / 720 x 576 px / sampling 0>2 / Mitchell

Else, i saw your elliptical sampling, it’s very interesting !
I search it in MR renderglobals and file texture properties, how can i use this sampling ?
PS : I use Mac G5 and OSX



Yes, I just had a look at this picture http://www.rayfresh.com/CG-images/pb-terre-map.jpg

There is a 2dplacement bug.
It happens quiet often! It’s like some nodes are corrupted.
If you can reproduce, please refere it to alias!

Is your earth object still a nurbs surface?
Did you modify 2dplacement settings?

I suppose you didn’t and you’re right!
For a stupid bug I can only give you a stupid solution:
Delete the shader of earth and rebuild it with fresh new nodes.


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.