Help! Stepping geometry with volume builder


#1

I’m a relatively new C4D user and I’m trying out the volume builder/mesh tools. I’m getting this really ugly stepping in the geometry that corresponds with where the voxels are. Is there a way to remove this or smooth the geometry without dramatically increasing voxel count?

Mesh and Settings


#2

You have to put the volume builder under a volume mesher to get the final result


#3

What you are seeing is exactly as you describe. The “smoothness” of the final mesh is determined by the voxel size. This is why the volume building toolset is useful for some things but not everything.

I see you already have a smooth layer in your volume builder. What id recommend is doing your modeling and work at a moderate voxel setting, and then before render, reducing the voxel size to where you are happier. If you use the Adaptive setting in the volume mesher (set at 1% or less) it will significantly reduce the final polygon count, while still retaining detail around edges, etc.

The only way to get a really nice, clean mesh is to retopologize.


#4

As I see he is using volume builder without parenting it to a volume mesher object


#5

Actually, all you have to do is use a smoothing Deformer.
Put the mesher as a child of a null, and add a smooth deformer as a child of the null as well…
Use the Deformer settings to fine tune…