Help! OpenCL is disabled


Hey everyone :smile:
hope your all having a great Weekend!

Currently using Maya 2020.1 and I am having troubles trying to use the Interactive Grooming Tools from Xgen… When i try to use a Tooli get the warning message that OpenCl is disabled. The Output Window says “OpenCL initialization has been disabled by user” on startup.

What i have already tried:

  • delete Prefs folder
  • re-install Maya
  • clean Re-install Nvidia Driver (already was on latest version) (Only tried this because some people on forums were saying to try this)
    No idea what do to because i’m pretty new to Maya and stuff (Only a Year or so) so I am pretty lost. :frowning: !

And here my Stats:
GPU: GeForce GTX 1080 (Driver version 445.87)
CPU: I7-7700K

New to this Forum so sorry if I chose the wrong topic :confused:



It says “disabled by user” in your log, which means it’s turned off via an environment variable. Look for “MAYA_DISABLE_OPENCL”. It could be a global environment variable or it could be set in your maya.env file.


If anyone still needs the solution of this, go to documents - Maya - version you are using (2020, 2021, etc.) - select the ENV file labeled “Maya” - delete where it says “Disable Open CL” and save. Reopen Maya and you should be able to use xgen tools :slight_smile: