Help my fix this image (MentalRay/Lighting help)


#1

Ok, heres a little scene I have been working on, and need a little help with;

Scene details:
I’m using mentalray/final gather to render.
I have a Daylight system set up coming in from the left,
And a photometric ies light used for the lamp. (with an additional, normal, spot light in the same place purely used for volume effect, ver Parti_Volume…apparently photometric lights don’t work with volume shadows according to this ).
My mentalray render settings are just on the defaults (with the exception of the volume light set)

My main problems are three fold, and I suspect they are mostly to do with fine-tuning the render settings themselves;

  1. The image is too grainy, particularly showing up badly around the newspaper. I have tried rendering with Noise filtering on max, and this actually makes no difference.

  2. The blotch’s of light on the table to the right.

  3. The fact the volume light for the lamp is showing up over the lamps cone itself. Given the light starts from inside, this naturally shouldn’t be happening. Its almost like the cone is transparent, but its not. (metal shader, black).

Any help with any of these issues will be most appriciated.


#2

not sure if I can be much help but whats your AA and FG settings at ? , I found I had grain when both these settings where a bit too low .


#3

That document is a few versions old now. The Max9 bug between volumetrics/photometric lights has been fixed in 3ds Max 2009 and maybe 3ds Max 2008 as I don’t remember exactly when the fix first appeared.


#4

Well, I’m using 2008 which still has the problem when I tested it.
Unless I’m doing something else wrong, which the volume overlapping the cone might actualy indicate.

Well, the image above was made using the FG preset “High”
Here they are in full however;


#5

I’d suspect the parti-volume shader but it could also be low sampling on the area lights. To track down where it’s coming from I’d do this:
Enable the material override (processing tab) and apply a default standard material to the material override. Hide any glass in the scene as it will block the light since it will be given a solid material now. Disable any/all volumetric effects & render. If the grain is still there then adjust (increase) the sampling on your area lights to help remove it.

Once noise-free, or if it’s noise-free without making any adjustments then enable the volumetric effects and check for noise. If noise appears with the volumetric effects then you need to increase the quality of the volumetric effects to remove the grain. FWIW, I’d highly recommend rendering a separate volumetric pass instead. You can blur it, adjust it, remove the noise from it, etc… in post without suffering the longer render times.

Looks a bit like artifacts from a low quality interpolated glossy reflection from an A&D material. If you’re using interpolated glossy reflections then increase the quality of those settings to remove the artifacts. If it’s not interpolated glossy artifacts, I’m not sure.

Not sure I completely follow. But the parti-volume camera shader simulates a room full of fog/volume so the entire volume of your scene is ‘fogged’. Perhaps a volumetric atmospheric effect would work better here?


#6

Just to clarify the last point;

Left is what I got, right is a quick edit of what it should look like.

Pretty sure this is the non-shadow-problem mentioned above though, going to have to use a different type of light it seems :-/ (allthough matching it to the ies is going to be tricky).

I’ll have a go at your other suggestions.

Perhaps a volumetric atmospheric effect would work better here?

Dosnt work at all with mental ray.
And I’d rather not resort to multiple pass’s if I can help it as this scene will be viewed from a few different angles, some of which will have dof effects.
Might even be used for a qtvr file.


#7

Incorrect. Max’s own volumetric effects work fine with mental ray. Attached a working 2008 file illustrating this.


#8

Jeff your one cool dude !


#9

Odd, when I tried enviroment volume settings in a previous scene they didnt show up at all. I’m guessing exposure issues maybe.
Guess I’ll try that again as plan b.
(after all, I have another volume-light project coming up that requires light shining though multiple stain glass windows…so I’d like to get my head around this easy one first :wink: )

Nethertheless I’m still really baffled why I cant get shadows to work with Parti_Volume.
Been trying various combinations since I posted and none of them seem to work at all.
Either I get no volume, or a volume beam they goes though everything and isnt even occluded.
Its something scene specific, I know that, as making a bare-bones thing shadows work.

For anyone interested I made a zip of cut down version of the scene here;
www.darkflame.co.uk/temppics/cluepic3_lightingerrors.zip


#10

Just to add some more info to the thread:

Darkflame, about those sploches of ligth on the table - did you try turning you daylight system off? I’ve had many, many problems with mr daylight system and max 2008 (specially if lots of sky portals were used). Do you remeber that Jeff?


#11

Yes, your right, its something to do with the sunsystem, without it problems 1 and 2 vanish;

In this scene only one portal was used, however.


#12

Samples…Samples…Samples. Anytime you see noise in your renders, check your samples & image sampling rates.

Following the steps I outlined in my earlier post it looks like the very low quality /default sampling rates you’re using is what’s causing most of the noise/grain in your render.
A. You’re using extremely low sampling, both in terms of image quality (anti-aliasing) and area light sampling. Increasing samples = less noise but longer render times.
B. FWIW, there’s quite a bit of noise/grain in the wood texture that you’re using. That of course will show up in the render as well…but it’s not the source of the black/dirty looking grain, that’s just low quality sampling.

Attached a comparison render, notice how simply increasing the image sampling rate to min:1 max:16 (a good value for final renders) and increasing the sampling on the portal light to 128 samples clears the black grain.

NOTE: The volume light moves because I physically moved it closer to the opening. I don’t know if you’ll be able to block/occlude the light behind that small light fixture otherwise.

NOTE2: You may also want to increase the samples on the mrSun to smooth the grain from the sun shadows if that’s an issue.


#13

Cheers, that indeed fixs the first two problems.

Putting a higher sample range on the portal was one of the first things I tried, but not in combination with the general samples per pixal.
I get this as a result;

Which is pretty good.
Still some noise, but I actualy like the look of having just a little, so I’ll probably only tweak the samples up only slightly more so as not to remove all of it.

B. FWIW, there’s quite a bit of noise/grain in the wood texture that you’re using.

Indeed, I notice that now. But I’ve never been that happy with that texture, so I’m probably going to change it anyway.

NOTE: The volume light moves because I physically moved it closer to the opening. I don’t know if you’ll be able to block/occlude the light behind that small light fixture otherwise.

This is more side-stepping the problem then solving it, and dosnt really look right, imho.

I dont think the problem is specific to the light fixure being small, as even with quite a large barrier the volume still ignores it;

No atmospheric shadows cast.


#14

Doesn’t that go back to the bug mentioned earlier? I know the bug is fixed in 2009, but as I said earlier, I’m not 100% certain if the fix is in 2008 (apparently not). At any rate, due to that issue I’d ditch the parti-volume setup and use the atmospheric volume effect…but that’s just me and you may have other reasons for not already doing that.

If by chance you’re not using a volumetric atmospheric setup because you ran into problems setting that up, here’s a stripped down version of your file with an atmospheric light setup.

LINK:http://jeffpatton.net/Temp/volume.rar


#15

Yes, I understood the issue, thanks to your excelent guide.
Allthough the methods I tried as a replacment didnt work.

For instance, using the suggestion to add “Spotlight base” to the mr Light Shader slot on the light resulted in no volume at all;

(I tried also changing its type to “spotlight” in the dropdown, but that had the same effect).

Next I tried using a standard spotlight, and assigning it to the Parti_volume shader instead of the other light;

Again, no volume.
(not quite sure why I bothered with that pic, but the lightsource is in the center, trust me :wink: )
What other settings could potentialy affect if a Parti_volume appears or not?

The reason why I’m keen to learn how to use Parti_vo now, incidently, is because I’m also doing a scene with stain glass windows. As I understand it, other volume light techniques dontinherit the colour of light when cast though a transparent surface. So you would have a single colour volume, rather then it reflecting the colour of the surface its cast though.
Now, of course, I could use a projected map on a spotlight to do this with one window, but as their are multiple and the light is supposed to be coming from a single source, I think Part_volume is the way to go.


#16

Once you assign a light shader, you’re controlling the light by that shader. Meaning you have to adjust the intensity, shadow options, attenuation, etc. of the light from that shader. In fact, once a light shader is assigned to a photometric light I don’t think it should be considered a photometric light any longer.

Any number of things: Exposure control, the light settings (or light shader settings) such as the decay, intensity, etc…, whether or not you have geometry behind the volume effect, and of course the parti-volume settings.

The atmospheric effect can pick up color from transparent surfaces when used with shadow maps (mr shadow map of course since you’re using mental ray). See attached example render using the default atmospheric volume effect.

You should be able to get the effects you’re after whether you use either method. But IMHO it’ll take longer and be more work if you use the parti-volume shader. That being said, at this point it’s obvious that you’d prefer to use the parti-volume shader so I’ll just shut up about using the volume effect instead.


#17

Impressive the things you learn by reading other people’s problems. Didn’t know the atmospheric effect could be so powerful. That being said, what are its limitations compared to the infamous parti-volume?

As a side note - Jeff, you’re a walking school :smiley:


#18

I’m not sure of any real deal-breaking limitations on the atmospheric volume effect. Of course if you want something like volumetric caustics, then the volumetric atmospheric effect can’t handle that whereas the parti-volume shader can (albeit it’s rather tricky to setup). Also the parti-volume shader can provide volume to objects whereas the atmospheric effect can’t.

The parti-volume has more bells & whistles than the atmospheric effect…but it’s also more difficult to control than the atmospheric effect (IMHO of course). I’d like to see an updated (and simple to use) volumetric option for 3dsmax/mental ray, but I’m not saying the options we have now are bad.

LOL, if so it would probably be called something like “National Lampoon’s school of useless knowledge” :smiley:


#19

Amen to that!

If you use this kind of advertisement you’re sure to get lots of students!!! :beer:


#20

I gathered that, but apart from ticking the shadow option I couldnt see anything else to set;

Attenuation is off, and there isnt an intensity option I can see.

Attaching this light shader to the light simply seems to remove the volumetrics completely, rather then fixing the shadow problem.

The atmospheric effect can pick up color from transparent surfaces when used with shadow maps (mr shadow map of course since you’re using mental ray). See attached example render using the default atmospheric volume effect.

You should be able to get the effects you’re after whether you use either method. But IMHO it’ll take longer and be more work if you use the parti-volume shader. That being said, at this point it’s obvious that you’d prefer to use the parti-volume shader so I’ll just shut up about using the volume effect instead.

No,no, dont shut up, because I clearly was wrong here, and correct me as opened up my options a lot.
I got that impression from googleing around before asking here. Theres all sorts of threads by people having trouble with mr/volume, and I found a few replys suggesting that enviroment wasnt a perfect replacement.

I’ll still like to learn how to use Parti_volume, but clearly the difference between them isnt nearly as much as I thought :wink: