Help - Mental Ray splotches


#1

I’m trying to render a visual for work of a garden to a pub looking from the car park. Was rendering just fine until I added some more furniture to the scene and suddenly these black splotches appeared on the render as shown in the attachment. I haven’t altered any of the settings from the previous render which worked fine. Can anyone explain why this is happening and how to prevent it?

Thanks


#2

See here… http://forums.cgsociety.org/showthread.php?t=199472&highlight=splotches

It may help.


#3

i’m having the same problem, and i think, from experimenting and from reading other threads i’ve found a workaround.

basically, FG does NOT like 2 sided (check box in any material) materials, double sided materials, or anything where each side of the normal gets a material.

so, basically, see if that’s your problem. i found in my case, i had 2 sided glass. i unchecked 2 sided, now i have no black spots, and my render is faster…

oh, hell. well, i’m watching the scene render right now, and splotches just appeared. so i guess the above advice is worthless.


#4

:sad: None of the other threads on this seem to shed anymore light on the subject. The scene was rendering perfectly ok before I just added a few low poly tables and chairs and the black splodges started appearing. They don’t even appear in the same place, if I re render without making any alterations. I guess Mental Ray is just bugged. I wish my company would fork out for Brazil, far less hassle in my opinion.

If anyone has any further suggestions…


#5

Hey guys,

so far im quite sure that in your settings there is a failure.
Without any specific information its almost impossible to exclude you failure source - perhaps you can up your scene in order to
“kill” your splotches…

My offer…

NAIK


#6

i have been in trouble with FG too…
has anyone experienced black spots as the one i described here ?
for your kind of spots, i have experienced similar when having strong bumped raytraced materials with FG. When i removed bump the splotches disappeared…at last i replaced with displacement even though it was not necessary and more time consuming.
hope helped a little…


#7

@titopte, i’ve not had that problem, no. this is the first time i’ve had the black splotch problem, although, i’ve had the discoball problem once before-> here:
http://forums.cgsociety.org/showthread.php?t=200301

@naik, i’m jsut using about the same settings i use for all my renders… i’ts just this scene (material in scene most likely). i’ve tried several rounds of FG settings- about two days worth of change->test->change->test. ehhh… i give up. i’m about ready to PS the splotches out. rotoscoping, here i come!


#8

I’ve never ran into this problem…and you could say that I use MR quite frequently…However obviously there is a problem somewhere though so here’s what I’d do:

  1. I’d try to track down the offending geometry (or shader)…but I think it’s going to be geometry related. In Pixel Abuse’s case, this should be fairly straight forward. No furniture = no spots, put furniture in the scene, spots appear. Have a look at that geometry of the furniture to make sure there are no coincident faces, etc…

I’ve seen a similar problem, but it was black splotches and not round photon shaped black spots. The splotches were in this persons scene because he had the “video color check” option enabled in the render settings…I have no idea why that created the black splotches…but when I turned it off…no more spots and there was much rejoicing…lol.

  1. As far as this: “basically, FG does NOT like 2 sided (check box in any material) materials, double sided materials, or anything where each side of the normal gets a material.” I’d guess that only relates to glass…or other transparent materials wherein MR has to calculate light passing through that object.

Again, this is just my thoughts. Since I can’t seem to recreate this problem, I’d be happy to take a look at any of the offending scenes to see if I can figure anything out. If not, there’s a lot of very talented folks around here, so I feel certain that if we put our minds to it, we can figure out what’s causing this issue. :thumbsup:


#9

@Jeff- thanks for stepping in :slight_smile:

the first thing i do when setting up an install of Max is set up the preferences- including changing the video colour check from “flag with black” to “scale saturation”- and it was the second or third thing i checked when i ran into this problem this time.

the problem with my splotches is its completely random from frame to frame. in fact, i can render the same frame five times, and it will splotch on two or three times- in completely different places.

i’ll try to email you the file i’m having trouble with, as i’ve not been able to recreate it with a fresh file.

and of course, THANK you for taking time out of your sure to be busy schedule to help.


#10

I’d tend to place the blame on a material in the scene, personally. That makes it sound more like the spots are secondary bounces from a not-so-FG-friendly material in the scene. Since the direction of FG rays from the camera are random (based on Mitchel filtering, I believe), that would explain why they’re appearing at random.
One problem that can arise in FG comes from super-black (r,g,b <0) color values. Not only do such colors slow down the processing of FG and your final rendering, but they will produce black spots if detected by FG. In some cases, this can happen when calculations of the material shaders foul up - they might produce negative numbers.
Just something more to look for.


#11

Solved it in the end appeared to be related to the bump maps, when i removed all istances of them it rendered just fine. Thanks for all the help guys.


#12

now, i may be reading something into your terminology here, but are you saying “instanced” maps were the problem, or instances of “maps”?


#13

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.