HELP: Issues with Arnold in Maya 2019


#1

I have never in my 3D Artist career encountered something like this and I can’t find anything, anywhere, about it. I really hope someone out there can help me out as this is for my job and not a pet project. I will be posting screenshots and project files. Please let me know if I can provide anything else or if you want screenshots of anything else to help you help me.I’d like to preface that I am used to Mental Ray but recently updated to Maya 2019 which no longer supports MR but instead Arnold. So now I am trying to learn Arnold for Maya. I’ve been working on a dragon model for work. I modeled it, textured it, rigged it, posed it and began to light the scene/rework textures for Arnold materials&shaders/test render before I start animating and then I was to move on to rendering said animations. Everything was going smoothly and I had barley scratched the surface of Arnold, Arnold Lights and Arnold shaders when out of no where it started acting REAL fucky.I’ve tried to troubleshoot as much as possible but have come up with nothing other than it seems to only want to render one material (doesn’t matter what type or kind) at a time, for reasons unknown to me. I have one maya directional light (to be removed or replaced) and a aiSkyDomeLight for HDRI reflections/refractions as well as a subtle ambient light. It all rendered fine this week as I was learning and rendered fine last night. Out of no where, today, maybe something I accidentally clicked, the materials/mesh began to render as black. Or at least I thought it was black. I quickly found out it just wasn’t rendering them at all after allowing the HDRI map to be renderable. I “reapplied” the aiStandardSurface material called “dragonskin” that holds all the maps for the main bulk of the dragon’s texture. Lo and behold JUST that material rendered. So then I “reapplied” other materials… and then only one of those reapplied materials would render. It is only when I map the entire mesh and all other meshes under one material will it render.

What could be causing this? How do I fix it? I would really like to learn how to use Arnold. I’ve seen some amazing renders but as it stands I have hit a wall with this Maya file and can’t progress any further in my studies or for my job.

UPDATE: Reseting preferences seems to have fixed it and I removed project files. I am still curious how this issue could have occured as to avoid it in the future.


#2

Is it possible to activated the “isolate” feature?