Has anybody found a solution to max/zbrush obj export


#1

Hi

I am having a problem with importing lv1 object from zbrush and exporting that model back into zbrush and going up in the divisions.

I have gone over countless threads of the very same issue but no one has an answer that has worked.

Alot of people have suggested to try every feature on max’s obj export tool. Downloading various other scripts obj imp/export tool. But none of these awnsers got anywhere

Has anyone had any luck with getting this issue to work?

Cheers

Jim.


#2

I’ve never had problems with my obj exports to Zbrush. They were pretty much fine.

I got this plugin for the import though, I wanted to import very dense meshes, and this does it so long as max can handle the mesh in the viewport-

http://www.guruware.at/main/objio/index.html

There are presets for Zbrush, I tried em out and they seemed to work fine for me.


#3

i’m not aware there is a problem in max_Zbrush pipeline …nor the need for a special exporter

if you have some trouble , just give some pictures and i may be able to help …

the thing you should know is if you exported from Zbrush to max and you cut , inset , extrude … anything that will change the Number"total No." or the order"No. of each vert." of vertices … then you Will Lose the Model Divisions in Zbrush … and Zbrush will recognize this as a New Model ! …this is how it works !

SO , this should be clear … What you can Do in max With Zbrush model Lv1 is only Move, Scale , Rotate …verts -edges - polys …
OR … fixing The Uv Layout
and Whatever ,except >>>changing the No. or the Order of the Verts …

now regarding your described Problem …
there is a difference between an Obj and Ztl …

So , try this

1-load your Tool “ztl” in Zbrush and it should have Some Levels of Divisions
2-go Down to Level one and export As obj --> leave Zbrush opened and on the same level
3-import in max , move some verts or change the obj shape without Cutting or adding
new verts
4-in max , export Selected " not just export , this option exports the whole scene "
5- in Zbrush , while you are having the Same tool and At Lv1 choose import and import
the obj you Exported from max , now you can go up in Divisions !

and this is the way it works , and by this way you can change the Uv layout from those you have to those you adjusted

this has been there from version 2 , now with V3 … if you have SubTools , you may have some issues regarding the Size of the tools and its Sub-tools

i think its now Clear that Obj can’t Hold Levels Of divisions , this is only a Property of the
Ztl Tool

this is as far as i understand from your post , if you mean something else … please make it clear


#4

Cyfer, yes that workflow you explained is how I have been working. The thing is that if I do the same thing and import/export from maya instead it works.

But I need to use max to transfer uv’s from a duplicate in max, I find that the transfer uv’s in maya does not work at all. But saving uv’s out from the duplicate model loading them in the original (the one I import back into zbrush works).

Arcanox yes I have tried that plugin no luck though, there is no preset for zbrush, mudbox would be the closest any way I have tried all presets but nothing works.


#5

ok … its still unclear for me !

i didn’t try duplicating a model before and export back to zbrush , so i can’t tell about that

however …i don’t understand the need for duplicating the model
if you did a copy and fixed the uvs on it >>> why don’t you throw a uvunwrap modifier on the duplicate … copy this modifier and paste in on the original one --> Collapse
the model --> import in Zbrush at level1, have you tried his ?

again , if you could put things in 1,2, 3 format , i might be able to grasp the problem and hence able to help


#6

Hi Cyfer,
It’s been a while since I had to deal with this, but I remember reading that the OBJ importer that ships with max reorders the verts when you bring in a model from zbrush. I remember the workaround was to import your mesh into max (which messes up vert order), export the mesh out of max then reimport it into max to get the vert order correct again, then export out to zbrush. Is this what you were having trouble with?
I used to find if I didn’t do this when I brought a model back into zbrush and went up a subdivision level everything would explode.


#7

Ok forget the duplicate idea that was my final intension. But for now I export from zbrush (lv1 export) import that in 3dmax, straight away export that back into zbrush and it will not allow me to go back up the levels of divisions verts go everywhere. I do the exact same process in maya and it works. I also checked the vert edge poly count between maya and max and they are exactly the same.

I can post a screenshot of what happens in zbrush after I have re imported if you like.


#8

plunq you suggestion did not work for me. Do you convert to editable poly when you import?


#9

@dark_tranquiltiy
No , post a Screenshot of the Export Settings that you have to click ok on before max exports !
i think this is where the problem lies

@plung
i think you didn’t read the whole thread , i have no problem exporting Max/Zbrush
and i don’t think there is a problem in that , infact AFAIK, MAYA do change the vert Order by default and you have to uncheck this in the export options !


#10

cyfer http://img101.imageshack.us/img101/7100/exportoptionsww6.jpg

plunq I tried both editable mesh and poly no luck though


#11

the good News is I do understand the Problem now

the Bad news is i’m having the same Problem Now , lol

its funny i didn’t test that on V3 till now …
on the early days of V2 , i had the same Problem , and the Export Setting Were the Cause
and i just didi what you are doing now !
now they are not apparently with V3 …
about your Export Settings , there is nothing Except the # of digits are 6 on my machine
and i remember that was the right No. in V2 that worked well

you have to give me Sometime on this to test on my models , uptill now i just tested the Rhino model


#12

didntwork for me. What are your import options? multiple or single?. Also are you converting to editable poly before you export?


#13

ok , do you know any place to host images ?
i’m outta these now and things works fine , and i think you should see some pics

Edit :
nevermind this

try the following

1-import to max
2-Do whatever you need
3-convert to poly if you haven’t allready done so
4-Poly SubLevel
5-select All --> Smoothing groups -->Clear All
6-in the Export Options and in the 2nd Dialog --> just uncheck " normals and
smoothgroups"
7-import in Zbrush and Go up in Divisions -->Works fine Here

[color=Cyan]Edit again
Missed your Previous Ques. sorry
import in max as a single ! not multiple and the rest is defaults
[/color]


#14

imageshack.ws


#15

Tried your “edit nevermind this” didnt work, can you host your import options.


#16

http://img486.imageshack.us/my.php?image=importoptionszj3.jpg

http://img224.imageshack.us/my.php?image=exportoptionsxh6.jpg

i think i should ask you now for the ZTL tool , cause we are getting no Where now !
i understand this feels bad , and mayby you can’t or not allowed to show it , but sometimes
its the only solution , if you have no problem with that PM me With a link , and make Sure to save the Tool at the Lowest Level odf Subdivision

i spent 2 weeks to figure out how to remove the red Bands i get in Zbrush when i press uvcheck … and it turned out that max and Zbrush has kinda of different offsets for Uvs !
if you place a vert so close to the borders of 0.0 - 1.0 in max --> you get a red band in Zbrush !
if you just make it not So close --> everything is OK !

The Nevermind thing Was for the Hosting links and Not for the Method !


#17

I recommend to try this:
http://blood2oo1.atw.hu/obj

I hope it will work.

BlooD2oo1


#18

step 1 - in zbrush3 - export lowest res as an obj

step 2 - in 3dsmax - import obj file and lay out uv’s

step 3 - in 3dsmax - export geometry as obj .

step 4 - in 3dsmax - import the obj you just exported from 3dsmax, back into 3dsmax.

step 5 - in 3dsmax - export from 3dsmax as an obj file. ( you must export the file from 3dsmax 2 times , something to do with vertex orders or something.)

step 6 - zbrush 3 - open file in zbrush and export it AGAIN! as an obj file. ( again something to do with vertex orders.)

step 7 - zbrush 3 - open the hi res model without uv’s and go to lowest sub-d level. Store a morph target.

step 7 - zbrush 3 - import obj with uv’s, and under the morphtargat sub menu under the tool palette click the button named switch ( Tool > Moprh Target > Switch

You can now go up through the subdivisions without exploding mesh.

Wierd, I know.

I will do more tests to confirm this.

This also included triangles in low mesh.

Also, import/export preferences for ZBrush have all of the flip buttons to off. When exporting from Zbrush make sure that merge is set to on and group is set to off. Use default settings for max import\export.


#19

are these problems all down to the old inbuilt import/export obj options in max and not the obj importer exporter available as a free plugin from maxplugins.de or indeed the 3dsmax 2009 NEW object importer/exporter?


#20

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.