FumeFX render has a black box.


#1

Hello friends.

I have a problem here with an explosion scene which I created in FumeFX.
Have done all the simulations in FumeFX and could see the results. Here is the result of the FumeFX simulation.

Now when I render the frame in max I get a black box in the scene. Dont have any idea why this is happening. Here is the render of the scene.

Here is the max scene below where the explosion happens. I believe it is the FumeFX adaptive grid that causes the problem. It is the area of the adaptive grid that appears as a black box on the render. Here is the actual scene.

Please help me get rid of this problem.

Thanks all for the continued support.


#2

I am going to guess you are rendering in Mental Ray.

If so, make sure autovolume is turned on, also bump your grid up or down 0.01 if you grid’s Z-axis is at 0.0.

BTW this is the PFlow sub-forum :slight_smile: Post for Fume in the Plugins Sub-Forum, more FumeFX people may see it.


#3

Thanks Johnny,

Yes I am rendering it in mental ray.
Could you please tell me where the autovolume setting is? Thegrid is not at 0.0 on z-axis.

Thanks


#4

It is in the Render Dialog->Mental Ray->Settings Tab I believe.

http://docs.autodesk.com/3DSMAX/15/ENU/3ds-Max-Help/files/GUID-3C86B3A9-D670-4152-832E-3E1B37B89AC2.htm


#5

Thanks Johnny

Enabled autovolume. Still having the black box on render.
Not able to get rid of it.

As you said, I will post it again in the Plugins sub forum


#6

Try render through a camera

Try Moving the grid and resimming

Try hiding everything BUT the Fume grid and rendering

Try everything

Remember things like this to learn the most important aspect of max… troubleshooting :slight_smile:


#7

Thanks Johnny,

Right now working on some other things on the same project. Will post soon after trying everything you said.
Just don’t know why I get stuck everywhere.

Thanks again.


#8

Let me know I have seen that before, quite some time ago, and it seems that one of those seemed to do the trick. I have never really done anything with mental Ray other than test its general functionality.


#9

Sure will let you know soon. Well I tried a couple of things already, like in checking the adaptive grid, hiding everything. Have to dig in more and rectify it.

Thanks Johnny.


#10

Unfortunately I had to re-create the Fume grid.
None of my settings made any difference.

Here are the settings I tried:

  1. Changed the size of the grid.
  2. Unchecked the adaptive checkbox
  3. Resimmed everything
  4. Moved the grid.
  5. Placed all the helper objects inside and outside the Fume grid
  6. Did a scanline render [Rendered perfectly]
  7. Objects placed inside the fume grid didn’t show up in the render, but showed up when it was outside.
  8. Created another fume grid close to the defected one with default settings. [Rendered perfectly].

Finally deleted the grid and created a new one with settings copied from the previous one. Now I am seeing the render perfectly.

If in the future it happens again…

Thanks again.


#11

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.