Fully animate object visibility


#1

In Maya, if you animate the visibility of an object it doesn’t render in the colour, or any other pass.

That’s not the case in Max.

I have some Forest Pack grass and I’ve animated the visibility by making a visibility track. It works in the colour pass but not in the occlusion. I can see in the scene that the grass is still there so even though it’s invisible to render, as it’s still in the scene, the AO still sees it.

Is there anything I can do about this? Can I animate a layer, or the light bulb for the grass? I want it gone, not semi-gone.

Thanks


#2

What renderer are you using? Just did a test here and in Max 2016 Vray 3.30.04, an object whose visibility has been set to 0 doesn’t render in a VrayDirt ExtraTex render element pass.


#3

but if you animate it, the dirt won’t gradually fade away as the object will. Instead it will just pop off when going from almost 0% visible to fully invisible - 0% visibility. At least I used to have this problem. Setting VRayDirt to use transparency however, will fix this.


#4

Using vray 3.20.02.

The visibility change occurs over a single frame so there isn’t a fade.

Strange that it doesn’t render for you. With me, it seems to be rendering as black… which is also strange.

Here’s the grass AO when visible

Here’s the next frame when it isn’t visible


#5

Just yesterday i had to animate visibility on particles and they don’t react to the visibility tack as well, but i found a way and figured out a simpler method if you don’t need refraction! I think it should work for you as well :slight_smile:

1.Grab your vray material and plug into vrayBlend coat 1, you dont need base material.
2. Change blend amount color to black
3. Plug into blend1 white color, I used vray color but output by default is white as well and works
4. Animate the blend amount to your liking - 0 is transparent and 100 is fully visible.

the other way is using refraction and IOR of 1
Plug white vraycolor into the refraction map and animate the rgb multiplier from 0 to 1. Should work with output as well.

I hope this helps, i think the first method would be more appealing though :slight_smile:


#6

Have you tried animating the overall opacity of the entire material of the object?


#7

I created an account here just to say thanks! best solution for this problem