fluid explode suddenly!!why


im working on a fluid tornado project now,everything ok except one thing make me almost crazyyyyyyyy!some voxels have very huge velocity suddenly,that make fluid fill container
[li]immediately,and then ,u know ,the shape of tornado dissappear…i know the reason of sudden “explosion” is velocity,but there are lots of reasons cause velocity change,im not sure which is the real reason cause the “explosion”.could any kind tell me how coud i avoid the “explosion” occur.thank u so much![/li][/ol]


Sometimes, when velocity is high (high swirl, high sim rate, high detail solve on, or a mix of these) the simulation tends to “explode” as you say.
When this happens, OR you turn down your settings to make it not explode (so push down the swirl or turn off hi detail for example), OR simulating on a per-frame basis is not enough anymore. In this case you need to solve your fluid on a sub-frame basis.

To do this, open the animation settings, and in the playback settings, on “Playback rate”, instead of 1.000, set, for example 0.500. This way the timeline will play frame 1, then frame 1.5, then frame 2, frame 2.5 and so on.
So will simulate your fluid, not anymore 1->2, but 1->1.5, resulting in a more accurate behaviour of the sim when high velocities happen. This should also be used when simulating high speed moving objects emitting fluid, for example.

Adjusting the playback rate will only act as a preview though, since the data is not stored, hereby you cannot playback normally (1->2->3 etc) otherwise the fluid will explode again. In this case, you need to cache your fluid with the previous settings, for example: “Cache by: 0.5” instead of 1 frame, and “save evaluation every: 2” instead of 1.

Hope this will be of any help,


you can set your damp value in your fluid container from 0 to something small like 0.01.

this might help decrease your velocities and prevent your sim from “exploding”.


on this note, is this a bug in fluid sim in Maya?? I tested it with simple 3D container with fluid and one field (uniform blowing in one axis). after frame 200 or so the fluid start to ramp up in speed and a few hundreds frames later it “explodes” or “implodes”. And sometimes it ignores the uniform field as it behaving in earlier frames.Why?

Only happen when I started to use field with my fluids.

The auto resize ffeatures in Maya 2011 seems to fix this problem, although then I can’t have boundaries to kill off my fluids. I have to kill them through dissipation.

Thanks all,



hi aghawa,noticeus.it works ,thanks 4 u help!!!
but there is a new problem,my container res is 100 200100,frame range is 300,when i cache the fluid finished,there is a error ,“cant access the cache information of fluidshape”,fluid cache node is here ,but range is 0-0,not 1-300,anyway the cache seems useless,i dont know why.but if i reduce the res to 5010050,the cache will be fine. my maya is 2008 32bit and OS is vista 64,4g ram,ntfc format disk,could anybody tell me the reason?appriciate !!


anybody could help me?if necessary,i could upload my file.im waiting…


Do cache per frame or only cache the density grid. There is a file size limit of 2 gigs per file and long animations can go over this limit with single caches.



This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.