Flickering Dmap shadows


I’m trying to get some help on why my dmap shadows are flickering. I’ve tried a few things so far but I still get a flicker in the renderings. I’ve disabled the Dmap auto focus and set the focus width as well as enable use light position. I have 5 directional lights and have done this to all of them. Still no luck. I have several lights underneath the ground plane and some above positioned far away from the scene. Cast shadows is disabled on everything but one set of objects which are all in the view of the directional lights.
I’d hate to have to raytrace this scene. lol. I dont have the additional 5 years it’ll take to render. :stuck_out_tongue:



Not sure but I think all you can do is increase the res of the dmaps. Bringing the lights closer and narrowing them may also help.
But then of course if you want that soft shadow back you have to raise the Filter Size to some ridiculous value. Maybe you can use disk-based maps, not used it much because if anything more than the camera moves it looks screwy.

A hack that may help: a touch of ‘fake’ motion-blur in post, the kind that simply takes copies of one frame and pastes it over the adjacent frames - since the flickering is completely random from one frame to the next, blending each frame 50% over the one before and/or after will reduce the flickering a lot. In fact it works great with any kind of flickering.

Another theoretical hack, I’ve never tried: if you render the same animation but with SLIGHTLY different lights (maybe just tweak the resolution a tiny bit) you should get different flickering each pass. If you render enough such passes and merge them together the flickering should almost disappear… :shrug:


perhaps bumping up the Dmap Bias value would smooth out the flickering. increase it just enough to get rid of the problem.

[edit] also try working with one light at a time since the problem might be the result of only one light not set correctly. once you get one working try rendering two and so on.

-mental :surprised


Thank you for the tips. I’ve tried most of those options a bit after posting and just couldnt get it to go away. THe dmap resolution put way higher would probably have solved it but the calculation to create several dmaps at the res i needed them to be to work would have killed so much time. The entire scene has about 3 million poly’s and lights positioned quite a distance away. I decided to just render ray traced shadows from one of the lights on the most difficult area. The rest I’m gonna get in compositing. I have a few days left on this project so I’m gonna take these tips and try to get the dmaps to work right so I can have some nice self shadowing on some of the objects. Ill be back sometime to post success or not. Thanks again.




The problem is the directional lights. Since they do not have a bounding box like a spot light it takes your map and spreads it to fit the entire scene(whether its in the view of the camera or not). So a huge scene will have flickering maps especially when your zoomed in to a small area of it. To solve this you need to adjust the “mid distance” on the shadow for the directional lights. You said you turned off the autofocus on it, so you might have allready tried this.


Oh yeah sorry didn’t notice you said ‘directional lights’, brr I never use them, at least never when they have to cast Dmap shadows…

If it’s a huge flat landscape you have to light (which would mean it would be hard to light it in sections), try rendering the landscape without shadows (only painted shadows), then composite whatever should move around in the foreground over it. Many other tricks you could use, the main thing is you need to get that spotlight focused closer around whatever is moving in the fore or middleground. If several different things widely separated, try several different spots (or compositing).


Well, what I ended up doing was killing the shadows on everything but one main section and did just a ray traced shadow pass of it a few days ago. Rest of the work was compositing. I didn’t really have the time to continue tweaking the light. =/
Regardless, the project in my opinion came out pretty well, there are some things that bother me but the lack of time killed the fixes. lol.
I will most likely have it posted on here soon to show. It was a project for class. Had a little over a week to do it.

Thanks for all the responses



My friend has posted the completed project. Here’s the link




This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.