First Thoughts (Demo Release)


#127

Sorry, I don’t see your point. You have an option of cutting with ngons or without ngons. If you’re adding loops to a model that will be animated you don’t want to create ngons–you want quad loops. That’s why the option is there.


#128

well i’m not going to animate, i’m just modeling so I just don’t know why I need to turn it off/on when I do an edge loop, just another extra step plus if i have just a cube and i want to run a loop around it, that will create quads - once again why does ngons need to be turned off ?


#129

In that situation it’s irrelevant.

Since it’s a tool option, it should be persistent; turn them on when you want them, or leave them off. From my poking around it looks like the default is to not create n-gons, so if you don’t want to use them, you shouldn’t have to worry about them.

So, if you want to be able to model with n-gons, turn on the option, and if you don’t need/want them, don’t.

It seems to me that the idea was to bring an oft-requested feature to Cinema users without shooting the ones that didn’t need/want it in the foot.


#130

Yeah, it’s really nonsensical. If you want to use one option all the time you can save it (and a all your preferences) to “new.c4d” and all the defaults will be just the way you want them every time you start a new scene.


#131

with the exception of primitive defaults… :wink:


#132

i understand, so if I want to use ngons from the beginning, where exactly is the option to have them on ? i thought it was in the menu by pressing v ?


#133

It’s an option on the tool’s attribute panel. When you select a knife, bevel, extrude (etc) tool, look at the options available; quite a few of them have a “create n-gons” checkbox.


#134

Look in the AM when you activate the Edge Cut tool. There’s a checkbox called “Create N-Gons”.


#135

thx Adam
so yes then if I have a cube, make it editable, create edge ring, now if I turn off ngons it shows me the edge cut in the middle, but if I have ngons on nothing shows when I hit apply - basically that’s my question, why won’t it show the edge cut if my object will have quads ? plus I try to do an edge loop in isoline display, and it turns isoline off ? sorry to be so picky but i can do this in other software and I just want to make sure it works before i upgrade to v9


#136

Now this is strange:

Why is that? Is that some new setting?

And another strange thing; if I close the shape in R9 using the “close polygon hole”, then I can bevel the whole shape without a problem. If I however close the whole using the “bridge” tool and decide to bevel, then there are openings near those 4 points that make up the new polygon.

I also noticed that “show normals” is turned on in my viewport in R9. Why is it that I don’t see them when I go to polygon view?

I know, it’s an early demo, but I just hope that these things are going to be solved.
For now I’ll stick to R8,5 because I lost a lot of time by trying to figure out each time what I was doing wrong.


#137

Just tried it myself, and no holes here.
As for the old normal display just enable “Tinted Poly Normals” in the viewport settings.
The new default is the display with red (Front) and blue (Back) tinting.
Cheers
Srek


#138

To me, the behaviour when deleting points in R9 provides greater flexibility. The R8.5 result can easily be achieved by deleting 3 edges and a different result again is achieved by deleting the edge between the points.

No problem here either when bevelling bridged geometry.


#139

Thanks for the info about the normals Srek, good improvement.

As for the holes, I don’t know what you did (probably something else than I), but let me show again what happened;

I deleted 2 points, bridged a new polygon in points mode (assuming that those triangles are new polygons) and selected the complete object in edge mode and selected ‘bevel’ and I got holes. I don’t have the problem if I fill the opening with “fill polygon hole” instead of using the bridge tool.

Btw, what are these two triangles? (A). Is that a new polygon?

Used C4D v9.012 btw.


#140

No those are holes in the mesh. Be sure to optimize after deleting the points.I dont get that result either.


#141

Holes in the mess? You mean those triangles? How can you say that, these are triangles.
You can optimize what you want in v9.012 but those triangles don’t go away. There is really no nned to optimize in this example, so I don’t understand your suggestion.
These triangles that are created after deleting those 2 points are 100% polygons.
Just try every tool on them to confirm this, even object info says that the object has 4 polygons. So the bridge tool should close that last gap without giving problems with bevel.

See, in R8 you’ll have 2 polygons after deleting 2 points. That means I have to bridge those two triangles myself. Then after bridging the other hole and using the bevel, I won’t notice any holes.

I dont get that result either.
What result?

Mmm, and I thought I was putting a LOT of effort into it to make everything very clear, step by step… guess not

Again, I add a cube in R9, make editable, go to points mode, delete 2 points (then you’ll see those 2 triangles appear) and then I bridge the open hole by bridging left/top to left/bottom and right/top and right/bottom. Then I go to edge mode, select all and then I use the bevel tool and when I slide left and right while holding the mouse button I see the openings appear.

Now you guys tell me why I see this on my computer XP SP2, my wife’s XP SP1 and my son’s Win2k SP4 and none of you see this behaviour…
Sorry, but I don’t believe word of it, that is if you follow MY steps.

If you guys start to include steps that I never did, well of course then there is the risk to get different results. So my request is; please read very carefully what I wrote. (I know, it takes some talent)

I’m sorry, but for me it’s a BUG, since I’ve tried this on 3 machines now and every time I have holes in my mesh when I use bevel.


#142

I don’t know why it happens but it happens to me too.
But if you bridge your points horizontally instead of vertically it won’t happen.
Weird… Try it.


#143

Yep, happens here as well. Twilight’s suggestion of bridging the points horisontally doesn’t create holes, though. Weird indeed.

/Anders


#144

Mmm, and I thought I was putting a LOT of effort into it to make everything very clear, step by step… guess not

Its’ completely clear. You just caught yourself a nice bug. Don’t forget to report it :wink:

Cheers,

bunk


#145

Same here, doesn’t create holes if you go horizontally


#146

Ok, now I understand why it is; when you bridge left/top-left/bottom , right/top-right bottom, then you need to reverse the normal. Of course I don’t have the problem when I start at the bottom. Must have to do where you start bridging in the coordinate system. I always thought that going around the clock was the way to do it, I guess I was wrong or soemthing has changed. Anyways, problem solved (for me at least). Thanks for your help guys.