Fire not rendering through glass?


#1

Here is the shot without the glass:

And here it is with the glass:

The glass mat is a mia_matxpasses with “Glass thick” preset. And the fire are just preset fire effects. I set the particle shape to render in reflections and refractions already, but im no getting them to render. Please help.


#2

check out how many refractions do you have in your Render globals … you need to change the default value ,…


#3

Under the quality tab, I changed reflections and refraction from 2 to 5 and max depth to 10. The settings are the same for photon tracing under the indirect illumination tab. Fire is still not rendering.


#4

I have a similar problem with fur not rendering through glass. Using mental ray, increased refractions and reflections, still not getting the desired product. Probably caused by the same mistake/wrong setting/ whatever. Fiddling with renderer settings, and trying other renderers like Vray to try get a better result. :slight_smile: Let me know if you get anywhere with this, I’ll do the same.


#5

Having similar problems here with fur not rendering through glass. Also using the mia_X material, maybe that’s the problem here? Tried increasing reflections and refractions and scans and all kinds of things to the point where it took hours to render a pretty simple-ish image, and to no avail.

Currently using mental ray for this, as well as maya software, gonna give some Vray thingys a shot, and hopefully that’ll get us somewhere. Let me know if you get anywhere with this, I’ll do the same. :slight_smile:


#6

PFX and Fur will not render through reflections/refractions unless you convert them to polys or MR hair objects first. Standard PFX have no geometry for mental ray to render, and fur the same. They’re basically post-filters, PFX especially.

Convert your PFX to polys first, make sure all your ray-depths settings are consistent between the mia_mat_x and your main render settings, and make sure all objects are “Visible in Reflections/Refractions”.

This isn’t the mia_mat_x’s fault directly. It’s just part of the fun of mental ray!


#7

Hi!

In the Render Settings, set ‘Auto Volume’ to on or off (the opposite of whatever it’s on now) and that may fix it! That affects how volumes are interpreted.


#8

Yes. I think this’ll do as a solution… only problem… I select my fur patch, go modify>convert>??? how do i convert fur to polys now? lol :stuck_out_tongue:


#9

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.