Fibermesh curves don't show up


#1

Hi.

Why is it that when I import Zbrush fibermesh curves, nothing shows up?
It says the result has been imported but I don’t see it nor is it in the outliner.

(I’m also having little luck with getting the fibersToCurves.py working either).

Help!!! :banghead:

t


#2

Are you importing .obj or .ma? If you’ve been trying with the previous, try saving out the latter from ZBrush.

Cheers!


#3

I’ve actually tried both plus the modo format. When I try the obj file, it says its imported in the result line but nothing is on screen or in the outliner. When I try the ma file, it says unrecognized file format.

This is very odd.

However in modo the curves do show up via the lxo file format. (I just can’t do anything with them for some reason). Modo doesn’t recognize the obj format either.

Help!! :banghead:


#4

That’s weird. Obj works for me only in Max, btw.
Have you tried asking on ZBrush Central?

Cheers!


#5

Will do. Thanks.


#6

Have you tried opening the .ma file in a text editor and making sure there are actually curves in it? One other point is that you need to make sure the fibermesh is the active subtool in ZBrush before exporting it. I use the .ma option here and it works fine for me (going from ZB 4R4 and Maya 2012/2013)

Cheers,
Brian


#7

I can confirm that .ma works fine here as well. But there’s a workaround you can try, if all else fails or if you want to be a little more selective about which curves you actually want to keep in Maya.

Export the Fibermesh subtool as you would export any other mesh as .obj (not the curves via the Fibermesh menu) > import into Maya > use this script by Mario Baldi to create curves from the flat Fibermesh polygons.

 This worked very well in ZB4 R3, but I havent tried it in R4 yet, so there's a little bit of a chance that for some reason it might not work.
 
 Good luck!
 
 Cheers

#8

Mr. Horganovski

I opened the ma file and it does list my 50 nurbsCurve fibers. I think its a memory issue but now I’m gonna try RazorsEdge’s suggestion.

Thanks again to you both.


#9

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.