FBX again [export issues]


#1

Here i go again with my problems… Silo is an active part of my work pipeline, so this is kinda important. I want to export FBX to import into Akeytsu for rigging and animation, but each try i fail.
Please could we put our heads together and see what am i doing wrong… The FBX i export from silo doesn’t work in any other software i tried, obviously there is something i don’t know.

Thanks in advance guys.


#2

Hi outburner,

I’ve been exporting fbx from Silo to Zbrush to Akeytsu to get around the issue for now. I also notice that export selected to fbx exports the whole entire scene. Btw, i’m really liking Akeytsu for animation, it’s very focused and zen-like, like Silo. :slight_smile:


#3

Hey thanks for the reply Iron Bear! I dont have Zbrush… i can export to OBJ and convert in Unwrap3D, but that defeats the whole purpose of FBX in Silo.
Akeytsu looks and feels great, it might be a good idea for Nevercenter to get in touch with the dev team and do some cross promotion or social media thing… after they fix FBX export ofcourse.

Anyone else has experience with this issue?

Thanks.


#4

Aw man, I’m bummed Silo’s FBX files don’t port over cleanly to Akeytsu, I’ve really been looking forward to trying it. It would make a really nice one-two punch for streamlined indie asset creation.


#5

Exactly!

Did you try exporting yourself? Just to be sure its not some weird hardware configuration or os glitch (win7 64bit in my case).


#6

It seems to come in to the new Lightwave 2018 modeler. I had to rotate it, but it then went into Lightwave Layout no problem.
They have a 30 day demo.


#7

I can open a Silo 2.5.1 FBX in Blender 2.79 but it comes into blender very small with the default scale factor so it looked like there was nothing there.

I can also open it just fine in Fusion 360. I have nothing else to try on my work system.

I notice your Silo version is beta. Can you test the release version?


#8

oops… updated and same errors everywhere :frowning:


#9

I’ll try on my sons laptop tomorrow… it might be some weird hardware software combo… :confused:


#10

OK, it works on his computer. So the problem is here… i cant think of a logical explanation. My computer is old, but all other 3D software works including all versions of Unity with all the fancy import/export formats.
Some dll in the wrong place? this sucks… any ideas?

Thanks guys!


#11

Seems strange indeed. Can you open the FBX file saved from you laptop on your workstation and does the FBX from your workstation open on the laptop?

I wonder if there may be something weird in the actual file paths or names.


#12

Thanks a lot for the time Cinnsealach, after all these years you’re still helping!

Ok, all the files work on the laptop (the ones from the workstation and those created on the laptop) and none work on my computer. So the problem is here, but what is it?

Thanks to all!


#13

It loads fine into Unity for me, though I had to manually assign the shader and material in Unity, which is no big deal, but I also have the black texture issue in Akeytsu.


#14

Happy to help when I can :]

Could your Anti Virus be causing a problem? Try disabling it if you have not already.


#15

what the??? Never thought of it. Will try.

Thanks!


#16

I went ahead and bought a new fancier computer (it was about time) with win10, 16Gb ram, etc. Exported the FBX again… and:

  • it imports in Blender
  • BLACK in Akeytsu
  • DOESN’T work in Unity (no errors, but no geometry)
  • opens in a 3D app that comes with windows apparently (mixed reality viewer), BUT the smoothing groups are all wrong, some are all flat shaded, others smooth.
  • opens in Rocket3F (Nvil) and when resaved from there, it works in all programs.

Could someone just export a model from Silo to fbx and attach it here please.

Thanks


#17

Yesssssssssss!
Thank you Nevercenter!!

[quote=]Silo v2.5.2 is now available! This update includes FBX materials and texture loading/saving, improved material editing and saving within Silo, Scene Editor improvements, and a few more small updates. Here’s the list of what’s new:
Added support for loading/saving of materials and textures in FBX.
Added a combined Diffuse and Ambient color picker to the Material Editor (to save time when setting both fields to the same color).
Fixed Save Selected Objects to only save selected objects in FBX.
Fixed Save Selected Objects to only save out relevant materials in all file formats.
Fixed an issue with Revert to Autosave filenames.
Fixed scrolling and selection bugs within the Scene Editor.
Updated Scene Editor to open expanded by default.
Updated Load Into Scene to select and highlight newly-added objects.[/quote]It works now!!! YESSSSSSSSSSSSS
Akeytsu - OK
Unity - OK
Unwrap 3D - OK
Blender - OK

Thank you! :bounce:


#18

This is radical, thank you Nevercenter!