Export Format That Preserves Scale Information?


So one thing that kills me with Silo is that .obj is the one file format that everything can load. But the scale information means zip to nil. I am having a terrible time getting the scale of a model from Silo pulled into Modo or Blender exported as an fbx and then have it be the correct scale in Unreal Engine. Do ANY of the other formats Silo exports to support better scale information?


I joined a team working in unreal, and while i dont know the engine or the scale they have set up for the world, i scale my silo objs by 100 and they’re the correct scale in the engine. Maybe this info is useless to you, just sharing :stuck_out_tongue:



I had someone ask this question a few months ago and figured it out so…

Under “Editor/Options” --> “General Settings” … you want to set Units to Metric and Unit Scale to 100.

Silo likes to work in meters, so if you want something that is 180 cm tall (the size of a UE4 base character asset), you would make your model 1.8 m tall. When you export it this way, into .obj, your object will import correctly into UE4 (assuming you didn’t mess with Import options there…keep Import option Scale to 1.0).

What I also have done is set my “Editor/Options” --> “Display Settings” … and set my Work Grid Width to 10m, my World Grid Spacing to .1 m (10 cm, basically), and Work Grid Heavy Step to 10. This gives me a nice big working grid to see where each small square is 10 cm in size.

Another important note: Silo uses a “Y-Up Axis” method, while UE4 uses a “Z-Up Axis” (sometimes called Left or Right handed axis). So when you are at the Import stage in UE4, make sure you put in 90 for the “Transform --> Import Rotation: X” value. Otherwise your objects will come in ‘sideways’.

Using this set up I can model UE4 assets without messing up anything.


For anyone who uses 3ds Max I have my units set to Metric, Unit Scale: 1. When I import the model into Max I have to be sure to check the box for ‘convert to metric’ in order for everything to scale in correctly. I don’t model for UE4 so I don’t know what to do after that.

On a similar note, but somewhat deviated, when I import a Silo model it is brought in as a Editable Mesh with ugly smoothing that I can’t get rid of (dark to light shading around edges). To fix this:

I select all the Silo imported objects,
choose Edit Poly from the modifier list (if you do it any other way it doesn’t work),
set the Faces subobject mode,
select all faces (4 on keyboard), go to Smoothing Groups and delete all

This will remove all those ugly smoothing groups created when it was imported. This is probably because it doesn’t have any UVW information (guessing about this).

Typically I end this with:
right mouse click on Edit Poly and collapse the stack (choosing to keep objects separate is what I usually do). This step is absolutely necessary but it prevents having a long modifier list.

So, if you use 3ds max and import a Silo model and you get ugly smoothing this will clean it up.