export animation - Maya to Max


I have a geometry that was modeled, rigged and animated in maya. Now that the animation is done I need to take it to max. I tried exporting fbx which works for things like translate, scale and rotate but not for any verts that where hand animated…

How can I bake the vertex animation so i can then take it to max?

So far i’ve tried these two ways…

  1. edit, keys, bake simulation (default settings)
  2. edit, keys, bake simulation (default settings + control point checked)



i was told I could export the animation as a geometry cache using an xml file, and export an obj of the model. Import the obj on max and apply the point cache… problems is i dont see how i can cache the geo as an xml, I only have the option to do it as an “mcc” (cache format).




convertPc2(pc2) boolean create
Convert a PC2 file to the Maya cache format (true), or convert Maya cache to pc2 format (false)


newest fbx-plugin is recommended:


  • backup your file
  • select all polygons related to the animation
  • mesh --> combine
  • with the object selected go to “geometry cache --> create new cache” (with default settings, mcc is fine, because a xml is written anyways)
  • delete everything in the outliner except your cached polygon object
  • select the object and choose “create --> sets --> quick select set” and give it a name
  • now choose “file --> export selection”
  • in the fbx-dialog under Animation check “Bake Animations” and also check “Geometry Cache Files”, select your Set in the Dropdown-List and export the file
  • when importing in 3dsMax you can uncheck “Animations”, because the Animation is driven by the cache
  • you can edit/customize the animation starttime, timerange, etc. in the point-cache modifier-settings


thank you, that should do it.

They way I managed to export it was creating a geo cache and exporting an obj. Then in max I imported the obj and applied the point-cache modifier… It worked but the geo cache I did I had to rotate it in maya because maya is Y-Up while max is Z-Up…



just one additional stuff for FX ppl:)

if you do not want to include puppets, bones etc (meaning exporting only animated object as an emitter for FumeFX, Krakatoa or whatever…)
After you combined > created geometryCache, make sure to delete

“polyUnite” node.

You can delete everything except your cached object easily.
Then doing following stuffs as diligent said.

Importing fbx into 3dsMax will be much faster due to there’s only cached object i guess


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.