Explore popup hiding behind main window on Linux


#1

Hello,

I’ve just realized that when pressing the ‘Explore’ or ‘Selection’ buttons (among others), the popup list will only show in front of the XSI main window for the first time I open it. Every following call will have it open in the background and I can only ALT+TAB it back in front.
I am running Foundation 4.2.0.1 on KDE 3.3.2. I’ve also played with the KDE window settings for a bit but have not been able to resolve this.

Any ideas how to fix this?

Thanks


#2

Could anyone running XSI under KDE please post his “Window behavior” settings so that I can at least compare them to mine?!

Thanks


#3

Have you set XSI to “always focus” or “always on top”? remove that if you have that… I’m running WindowMaker so I can’t really help out with KDE.

regards
stefan andersson


#4

@StefanA
You can’t even set this, as the window does not have a title bar where you could click on to set this option. Thanks for the input though.

I have however managed to get it running by creating a new window specific behavior rule:
[ul]
[li]Create a new “Window specific setting” and give it a description such as ‘XSI’ (all following text without the ‘’)
[/li][li]Window class needs to be ‘Xsi MainWin’
[/li][li]Check “match whole window class”
[/li][li]On the “Windows extras” tab set “Window title” to “Regular Expression” and enter ‘^$’ (which basically means that the window has no title)
[/li][li]On the preferences tab, check “Keep above” and set it to “Force” and check the box right to it
[/li][li]Close the window by clicking “OK” and then hit “Apply” to activate
[/li][/ul]
This setting will force the popup window to always be in the foreground. The hard part was finding a way to specify that the rule should apply to a window which had no title…


#5

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.