Everytime I try to make a brush stroke, "Subdividing Geometry to x Quad-Polygons..."


This is driving me crazy. I am using Zbrush 4r7 on a 2011 Macbook Pro. I am new to Zbrush but thought I had figured out all of it’s fun little bugs and inconsistencies. Suddenly, Zbrush now believes that every time I want to use any brush, that I would like to Subdivide. It lags, my UI says “Subdiving Geometry to x-number Quad-Polygons…” and then doesn’t do anything. It doesn’t go through with the subdivision. It doesn’t adjust the topology in the way I wanted. It just does…nothing. :banghead: I gave the program a couple days to breathe. I used Ctrl+N to clean the canvas, and reloaded my tool. Same thing happens. :banghead:

To make matters worse I tried to register and post at ZbrushCentral, which turns out to be several measures more complex and impenetrable than Fort Knox. (Even telling me I had failed a CAPTCHA which DID NOT EXIST when trying to email the Forums administrator). Haha. (Sorry to digress). Please help!


Trying to fumble blindly through the Zbrush learning curve is about as frustrating a thing as you could do! :slight_smile:

Go to Zclassrooms on Pixologic’s site. There’s a ton of tutorials on all aspects of Zbrush. You don’t need to register, and you will be saving large chunks of your hair in the process.


Thank you for your response, but I didn’t really have much of a learning curve with Zbrush. I’ve built a photorealistic model already, from Zspheres to Polypaint. The only counterintuitive thing about it is the UI, which at this point I’ve completely customized to my liking. The problem I’m describing is a bug, not a feature. I’ve got a 3d tool, in Edit Mode, which I can rotate and zoom around. And everytime I try to use any of my brushes on it, it gives me that “Subdividing Geometry…” message, and changes none of the polygons. That is NOT normal.


I have encountered the same problem. I don’t have a permanent solution as to how to get it to stop doing “Subdividing Geometry.” However, I initially thought that it had to do this too many poly’s on one subtool, so I would hide part of the mesh using the “Ctrl-Shift+marquee select” on parts I wanted to work on. The message stopped showing up and work returned to normal until the whole subtool was un-hidden. I realized that even if I hid one poly from a subtool, I can work like normal. I have also realized that I can bring in different Ztools with no problem. It just happens to be this one ztool.

It’s a small work around and nevertheless annoying, but I would hate to see all the work done on this project wasted.

Hope this helps…


I had this issue pop-up with one of my sketches…I tried saving as a tool, and importing it into a new project, and that didn’t work, but exporting as an OBJ, and creating a new project did the trick.


sounds far more permanent than my suggestion. However, this would require one to merge all the subtools into one, which may make it more difficult to work with or require breaking it back up into separate subtools after the .obj import. If this route is chosen, be sure to designate subtools with corresponding polygroups to make separation easier.



I got this same issue today, but I think I have it figured out: I somehow ended up with Dynamic Subdivision enabled… seems like it’s a type of subdivision preview instead of actually subdividing and it’s essentially a toggle on/off feature. Shares the same hotkeys as classic subdivision - “d” to enable, “shift+d” to disable. So yeah, shift+d should turn it off and fix your problem.


unitZero8 thank you! You saved my fucking life man!


thanks u helped me a lot


OMG! it saved my thanks a lot man


thanks man !