Error: setToolTo: Object '1' not found when hitting "scale" hot key


#1

Every time I hit the scale hot key, it gives me this error: “Error: setToolTo: Object ‘1’ not found.” It doesn’t do this in a fresh scene file, only on a specific scene file I’m working in. I’ve researched and managed to find solutions that have worked for others, but none of them seem to work for me. I’ve tried importing my scene into a fresh one, no fix. I’ve tried resetting my preferences, nothing. I’ve tried deleting the prefs folder, to no avail. I’m at my wits end, I don’t necessarily NEED to use the scale hot key, I can still use scale if I click the icon in the left toolbar, but it slows down my workflow and is just generally annoying. Has anyone else had this issue and/or able to help me solve it? I would seriously appreciate it.


#2

Do you have any objects of any type named ‘scale’? A layer, group, light, mesh, anything?

If not, save the scene as a .ma and open in text editor and search for ‘scale’. See if you get any strange hits.


#3

The only things I can think of are that I have an attribute on my master node I named “GlobalScale” and a control curve I named “pupilScale.” Should I change these to something else?


#4

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.