ePMV and C4D R18 Mac


Is ePMV compatible with Cinema 4D R18 on the Mac? (I know there is a Windows version). It used to work fine in R17


I have had a lot of problems getting it to work in 18.When I need it I open my R16 or 17 version of c4d and that stiill works fine. You can contact the developer Graham Johnson on the website–he’s usually pretty responsive.


Joel: Thanks! That’s what I had feared. I had deleted my r17 when I got my new iMac. I’ll try to contact him.


It could just be an installation issue or a version thing. I know one of our guys did get it working in R18. I just havent had any luck


Deleted initial remark because I had names mixed up.


It works fine here; just make sure you have installed X11 ( https://www.xquartz.org/), which is required for some parts of the PMV core.

It’s unfortunately easy to forget that X11 is required…


It works! I missed that Quartz X11 was part of the installation. This is the second time that you have been extremely helpful. Thank you!!

BTW, I just got someone turned on to your NeuronBuild over at C4D Cafe and she loves it.

Don Ross


In my case–I had x11 installed, and the other plugin installs I have work.
ePMV loads but gets crashy or hangs when trying to load a pdb in R18.

Probably something I did wrong in the install if no one else is having issues.


I am finding that if I work with small to medium molecules like 3QQT, all is well and gorgeous molecules are constructed. But when I go with big ones like the nanotubule 3J9R.cif it locks up C4D and I have 32 Gb ram but it did have over 103,900 atoms.

The Cystic Fibrosis Transmembrane Receptor with 9227 atoms just worked fine.

As it turns out, what I was calling a lock up was lack of patience on my part. I gave 3J9R 20 minutes undisturbed to render in the viewport and I got a beautiful 103,900 atom molecule. Atoms take way longer than ribbons.


Hey there, I am having trouble to properly show ribbon representation for the PDBs I have saved from PyMol. They look like coil.

If I fetch from PDB ID it looks fine.

I tried both windows and mac versions on C4D R18 and R16 respectively with no luck.

I need to use molecule files extracted from PyMol since I superimpose the positions of certain molecules and I need this positions as I made them.

Does anyone face the similar problem or have a solution?

Thanks in advance.


Try joining this group

The fellow who created ePMV frequents there and most members use the plugin.


You are likely to get an answer there if you dont get one here.


Thanks, I applied to join. I also e-mailed Graham J. So, hopefully someone can help.


There’s also a preference checkbox setting in ePMV that allows PDBs to come in not at world center. Maybe that could help.


Did you get a reply? I had it working in R19 but no luck in R20. Looks like there could be some Coffee code in it.


Try this (swiped from veronica falconieri on the google c4d scientific animation forum)

Here’s the full report for anyone else who may be troubleshooting on Windows:
The ePMV plugin was not working from within in my default Cinema4D preferences directory (retrieved from within C4D, Edit > Preferences, looked something like: C:\Users\Veronica\AppData\Roaming\MAXON\Cinema 4D R20_123456\plugins).
(Weirdly, CV Artsmart did work when I put it here as a test…)
Following Josh’s guidance, I looked for a plugin folder inside C:\Program Files\MAXON\Cinema 4D R20, but there wasn’t one.
So I created a folder named “plugins” (C:\Program Files\MAXON\Cinema 4D R20\plugins) and copied the extracted ePMV folder there instead.
Restarted C4D, and ePMV was there.


On that note I’d urge anyone who does science/medical animation in c4d to join the group–these sorts of technical issues/solutions come up all the time and the author of the plugin frequents the forum.


There is a thread there with more info.