Don't affect children


#1

Hi,

Does anyone know how to turn ‘dont affect chidren’ on and off with Maxscript?

Thanks in advance

Spencer


#2

I once had to do this and had the same problem. The solution I found was to unlink children, do my stuff, and then link back.


children = for obj in myObject.children collect obj
children.parent=undefined
--Do something here
(children as array).parent = myObject

hope this helps


#3

Yes Ive been using something very similar to get me by:

select <node>
max unlink $
[do something]
$.parent = <node>

Thanks for your help Charles


#4

Sorry about this just one more question…

Does anyone know how to turn the IKHI Solver ‘Enabled’ state on and off with script?

Thanks again

Spencer


#5

It appears Paul Neale had answered this question before, I just found it.

–Turn if off
$.controller.enabled=0

–Turn it on
$.controller.enabled=1

Thanks

Spencer


#6

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.