Displacement map trouble


#1

Hi guys, I use zb4R4

My problem is about ‘faced’ artifacts on displacement maps.
here is the workflow i followed to create my tool :

  1. I created this mesh inside zbrush using both dynamesh and standered sculpting methods
  2. Used qremesher on the elements (teeth and gum separately)
  3. Subdivided the new topologies and Projected the details on to them (teeth and gum separately)
  4. Stepped to the highest subdivision level and merged visible subtools to created a single subtool with all the elements
  5. Stepped to the lowest subdivision level and exported it to 3dsmax as an obj
  6. unwrapped uvs using 3dsmax uv tools
  7. exported the unwrapped model as obj
  8. loaded the tool i created in step 4 (using merge visible) and stepped down to the lowes level.
  9. with that tool selected at the tool pallet, pressed import and selected the unwrapped obj model that was exported with max.
    (as i know zbrush automatically assigns the new uvs to the tool from the unwrapped obj)
  10. then lastly asked zbrush to generate displacement maps

but unfortunately this is what it generates :

As you can see the displacement map is a mess, with ‘faced’ artifacts all over.
I tried tweaking all the settings, with adaptive mode on and increasing subpixel accuracy bla bla bla…, but same result all the time.

And this is how its shown on the zbrush viewport :


with displacement : on


with displacement mode : on

Can anyone tell me what maybe going wrong?
I also tried importing the unwrapped model as a separate tool and copy and pasting uv set using uv master. but same result.


#2

None of your images are showing. Are you trying to generate maps for a character, teeth, and gums all as a single subtool?


#3

Sorry… now are they visible?
I was just trying to generate maps for teeth + gum


#4

What do your UVs look like in ZB if you click the Morph UVs button?