Disabling Spacebar


#1

Hello. I know I am not the only one that has the annoying problem with hitting the spacebar accentually while performing a very delicate proceeder in 3ds max. I have never found a any use for locking anything down in Max.
Touching the spacebar creates many problems as one has not clue what’s going on and I often end up make unnecessary undos only to find the spacebar had locked some part of the object I was working on. I do not have big hands.

I have looked everywhere to find a way of disabling the spacebar without having to go into the register and totally disabling it. There is no mention of the spacebar hotkey in the Customize user interface. I imagine it might be possable to make a script that can do this job. But I got no time or way to learn Max script.


#2

change the hot-keys


#3

there is no Hotkey for the Space bar. If I knew where it was I would have fixed the problem


#4

this is completely false. either you havn’t tried it or you don’t know how. go to customize - customize user interface - keyboard tab - click in the hotkey box and press the spacebar. you can reassign it. or alternatively remove it from the default action of “selection lock toggle”


#5

Ok I tried to follow you instructions but after I press the space bar the word “Space” appears in the hotkey box, Below that the label Assign to selection toggle. but the Assign and Remove buttons are greyed out


#6

You have to select the assigned function (“Selection Lock Toggle”) in the listbox to the left. After that you can remove the shortcut or assign a different shortcut to it …


#7

The purpose of locking your selection is not just to “lock” it, it can be very useful if you want to interact with something without having to actually have the cursor interactive with the transform gizmo. And sometimes it’s good not to deselect whatever you are working with, just like pinning focus on modifiers can be really useful too.


#8

Locking is incredibly useful for advanced transforming and snapping operations. You can snap from and to anything when transforming, but not if you rely on transforming only using the gizmo. That’s what it’s for.


#9

Thanks guys. I finally got it figured out. It was not a straight forward step by step operation to disable the space bar. You guys probably are used to reassigning keyboard short cuts. I only tried it once about a year ago. I followed a tutorial that suggested reassigning the Shift + X short cut for edge constraint to the Key D. I undid this operation because now and then I make tutorials for 3ds Max. I make tutorials on subjects that are not explained well by the manual.
Example using the Working Pivot to move the pivot point to a chosen vertex. I watched a vidoe made by the Howto 3dsMaxHowTos where the guy narrating struggles to explain how to use the Working Pivot. I have also seen a few people on this forum ask who to move the pivot point to a vertex.
I guess I will have to make one on this topic because it is not that straight forward for beguiners.
I have used the lock button before but I have had no use for it thus far. I see many people want to give up on Max because they press that key and can not figure out why their mouse button has stopped working


#10

snap vertex mode --> edit working pivot --> move pivot to wanted vertex
Frankly I dont know how more straightforward that can be…

I must be using the lock function hundreds of times a day.

Oh boy, wait til they meet up with Max’s real idiosyncrasies :argh:


#11

depending on your age and where you 1st learnt 3ds Max it might all be straight forward. But you easily omit the fact that after moving the pivot point you also have to tick use working Pivot. There is a lot of tool switching.
I 1st started learning Animation and 3d modeling with Animation Master. It was more straight forward to use then 3ds Max. In many ways it is was better then 3ds Max. It’s only fault was it would randomly crash. I have only been learning Max for the last 3 years. In March I tried Blender for the 1st time and I was making and uploading mesh to 2nd L.
I spend more time leaning 3d in Max then other sofware


#12

My spacebar is the “Play” button…


#13

:banghead: thanks for reminding me. Knowing me 3 months from now I will be back making animation and asking why my animation does not work when I hit them space bar.
:banghead: but what a moment. I have never used the space bar to play an animation. so I will see how it goes.


#14

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.