Depth of Field Trouble in Maya 6


#1

I have a question about the Depth of Field settings for camera’s. I have a bunch of tubes protruding from the sphere right, and the camera is about Translate Y=170 of the grid, right and the sphere is at 0, so the camera is 170 units away right, what settings what i want so that the sphere is perfect focus and tubes gradually fade from really blurry closest to camera to perfectly clear farthest from camera?

i can get it sorta right, but the clear part has a weird haze around the objects

sorry i cant post an image, but any help would be greatly appreciated, thanks!

m@


#2

You need to enter a low f-stop value such as 2 for your camera settings.
Cheers


#3

When will ppl. learn: do DOF in post.


#4

When you start using capitals in your posts, like you do in your sig…
I guess this topic has been covered already numerious times in these forums CIM. No need to start another discussion. I guess you are better off to write directly to those who implemented dof into render engines at first place.


#5

Say what?

I’m just suggesting that it’s probably better to do dof in post. :smiley:


#6

ok thank you, do you know how to stop the weird haze from the clear (unblurred) objects, im guessing that the focal length would be 170 correct? (since the object is 170 units away - Translate Y =170)

thank you again for replynig


#7

You won’t be able to fix that. Maya’s DOF is ugly.

You can do it in post (as CIM suggested). Try http://www.frischluft.com/. It works okey, although it can get a bit fuzzy aswell (because of antialiasing in the ZChannel). Might have to render at twice the size.

Or you can do it in mental ray, wich does a very nice DOF, but it takes ages to render.


#8

hi, thank you for your reply, i am using mental ray, and it is lookin much better thank you, but i have another question, i am rendering with clipping planes, (custom) which means auto render clip plane is off, so as my camera moves it only renders things within certain range to camera, but when mental ray is used for rendering it auto renders clipping plane and doesnt keep the range, it just renders everything at all distances, is there something im missing to keep the auto render clipping plane turned off? i have been lookin for over an hour now and cant find it, any help would be greatly appreciated, thanks again!
m@


#9

anyone at all? please? hehe


#10

Matt,

Go to a local bookstore and take a quick look at the Learning Maya 5 (or 6) Rendering book. Look at the depth of field section. It should have what you want. It’s a straightforward one or two page section so bring a pen if you don’t want to buy the book. :slight_smile:


#11

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.