darkened faces??


#1

i have some darkened faces on my model, his toe in particular.
I know it means something but I don’t remember what is means, can somebody give a hand?


#2

i think you have non manifold polygons , if your model is in polys. you can turn on show non manifold geometry in the custom polygon dysplay and check. if that s it , either split the face correctly or delete it and append the border edges.

kinda tough to say without visual feedback though, you got a screenshot ?


#3

Your normals are pointing in some funny way, use either the “Set to face” tool to get faceted look, or “Smooth/Unsmooth” (Or something…) tool to get smoothed normals. Both can be found at the “Edit Polygons” menu, and then “Normals”


#4

thnx for the quick replies guys, i’m not able to send a screenshot now, but i will do tomorrow…

thnx again


#5

hmm, looks like ur suggestions don’t work, but here’s the screenshot anyway

normals??


#6

are you sure they use the same shader?
i remember trying to fix normals once and in the end it was 2 different shaders…

alexx


#7

it doesn’t even have a shader, i just put on a material, lambert, and changed the colour of it, that’s all. I didn’t use 2 objects and then combined it, it is all one piece, but i deleted a couple of vertices and faces and then ended up with this :annoyed:


#8

Try edit polygons>normals>conform. It looks like you’ve got normals pointing in 2 opposite directions.


#9

look at the normals…to make sure they are aligned…it looks manifold. sometimes extrusions do funny things if you are not careful…deleting can also botch things

in the end, render it and see if it shows up in the renderer.


#10

an easy way to know the normals are bad is if you set the display to show polygonal borders. this will creat a thicker edge display wherever there are faces with normal reversed. the easiest solution is to select entire mesh…convert selection to faces…then under normals…choose “conform”

anothe method is to turn on culling…so that you can only see the faces that have normals pointed towards the camera…any face that is invisible…has a normal facing away from the camera


#11

btw…those little blue dots indicate the center of the face…they are not the normals


#12

i have a question about 4.5…

do you see the option Veiw Faces of Selected Image in the UV Texture editor…i have it installed and i do not see it…although the mention it as a new feature in the help files


#13

you should also check your vertex-normals… if they are ****ed up, you can get exactely what is on your image
(go to the AE, check normals and select vertex normal to display.)

cheers

alexx


#14

You can also turn off the two-sided lighting to see if you have normals flipped.


#15

yo 2bits, i’m not into that part yet, so i wouldn’t know :beer:


#16

have u tried deleting history then playing with the normals? i’ve gotten messed up shaing like that, then tried to fix the normals and it didn’t do anything till i deleted the history, then played with the normals again


#17

You might have some “lamina” faces here…that can screw up the normals too. try deleting one of the problem polys to see if theres another one in exactly the same place.
Maya screws up normals all the time, so get into the following routine (for low- poly stuff anyway) :-

1. do a merge vertice operation with a low tolerence (like 0.01) on the whole object.

 2. pick the whole object again, then conform normals.

 3. delete history

 4. select as object yet again, and set normals to face.

That’ll fix most of your blackened face problems, about 99% of the time.


#18

thnx for all the replies you guys… haven’t done all suggestions, but sure whill, right now i’m modelling a character with sub-d, so less poly-worries for me


#19

I had a body and a head, exported from max, both UVmapped and as separate objects in the same scene, both with individual materials applied, when i 'combine’d and vertex welded them together i started getting black spots, assuming it was the normals freaking out i went through all of the suggestions above, but to no avail…
eventually i tried selecting a single polygon in an obscure area (back of neck) and applied the subdividing type of ‘smooth’ (polygons -> smooth - IIRC) and all of a sudden the entire mesh’s normals came good.
No idea why, but it worked… and NOW all of those other methods do what they are supposed to, whereas they didnt before.


#20

betlog…for your case you need to “unlock” normals…and then set normals to face…sometimes my models looks like somebody threw tar all over it…this method works best.