ctrl_buffers


#41

Uhmm… what’s so wrong about the useBackground shader? If that doesnt help, try Puppet’s p_shadow:
http://www.puppet.cgtalk.ru/download/shaders_p_e.shtml


#42

hey floze,

there’s nothing wrong with the background shader, except that in my testing it always shadowed in the ambient part as well. anyway, thank’s for the link, i didn’t know of it.

Thanks again for posting, it should help a few other people out here. I’ll try them out and see how they work for me.

AndY


#43

In Maya 6.5 the use background shader is working with final gather !

thanks a lot francesca for this very very great set of shaders!

and thank in advance for the multilayer.openexr !!

Laurent.


#44

I think we need to start building a giant marble statue of Francesca so we can praise her greatness all day long!

Franchesca you rock, I’m thinking we need a cgtalk working bee around at your place, lawns mown, garden weeded, hedges trimmed, dishes washed…I give great foot massages:love:

Thanks again, you unbanable(sp?) cherub:D

MunCH


#45

I’m lost (or similiar).

I have my scene with my mesh and many shaders assigned… Now i create the buffer_store in the hypergraph and start to put my shaders in the buffer.1, buffer.2 and so on… I’ve set the buffer_write to the output shader in the persp camera with the name for the output render… tweak the buffer_range to …3
Now i think i’m ready… So i render but in the output window i see many errors

PHEN 0.2 info : writing depth buffer to “last.zdepth.1.iff”
PHEN 0.2 error 051001: cannot map frame buffer: invalid fb index (14)
PHEN 0.2 error 051001: cannot map frame buffer: invalid fb index (15)
PHEN 0.2 error 051001: cannot map frame buffer: invalid fb index (16)
PHEN 0.2 info : -----------------------------------------------

So i decide to assign the buffer_store to the whole mesh and again the error came up…
Then i restore my shaders association and start to add the buffer_api to the invisible cube as read in the docs… Booom. In the specified path now i see the sad.user#.#.iff but they are black images… Ok, now, again assign the buffer_store to all and finally i see my outputs!!!

[size=1]PHEN 0.2 info : ctrl.buffers ----------------------------------
PHEN 0.2 info : writing depth buffer to “last.zdepth.1.iff”
PHEN 0.2 info : writing user buffer 1 to “last.user1.1.iff”
PHEN 0.2 info : writing user buffer 2 to “last.user2.1.iff”
PHEN 0.2 info : writing user buffer 3 to “last.user3.1.iff”
PHEN 0.2 info : writing user buffer 4 to “last.user4.1.iff”
PHEN 0.2 info : -----------------------------------------------

[size=2]Very sad story because i have no more the original shader assignment…

I suppose you’re about to laugh… but i’m waiting for a help!!

Is this procedure correct? Do i have to assign multiple buffer_store per mesh?

There you have my desktop… (i wish i can capture the reflex of my face too)… :twisted: [/size][/size]

Why nobody post a simple scene? Why this simple scene is not included in the shader download?

Thanks for reading my story

-elvis


#46

thanks for that great tool - it is just what i was looking for …

@elvis: i didn´t read all of your post (the “why does nobody…” thing was anoying me) but what might help you: material->buffer_store->SGroup … thats what it must look like … and the buffer write must be the output shader of the camera …

don´t know anything else, just getting started :wink:


#47

hey francesca

really cool but something is missing… write all the diffrent passes in one file (like exr) so maybe you have time to do something like that…
but big respekt for all the stuff

ghosh


#48

I’d kind of like to second a little more help.

The shader’s francesca makes are awsome, and really give users a chance to take MR to where it belongs, without having an in house programmer. That said, perhaps she should team up with Jozvax who could create somewhat better documentation, or somone else would help in explaining exact use, and perhaps some of the possibilities these tools provide.

Thanks again for supporting the community!


#49

Hi!

Now i ran into problems as well: A fast test yesterday worked fine, with one exception, i used only one object and one “color”-shader.
now trying to work with a more complex scene today, i can´t get it to work.
I just have to objects, to different color-shaders for them. what I want is a buffer output into 1 color-pass, 1 ambient occlusion and a shadow pass.
But i don´t know what setup i need to get the 2 color shaders connected to the buffer_store without wasting one inbuffer-channel …

Help and screenshots greatly appreciated!
Thanks,
Ulrich

EDIT
should have tested more intense first, then posted :wink:
sollution: use as many buffer_stores as you like or better: in every shading network one “buffer_store” node.


#50

Sounds like a job for the TripleSwitch. Check your docs on that.

AndY


#51

@ulei… Oh i’ve not read your full reply to thread (this EDIT anoyng me too) so i think you may read my post first, then start tweak your scene…

Thanks alot


#52

sorry - it just sounded like “i get something for free and start complaining because it´s not perfect”


#53

yes maya crashes alot, but this is v1.1… I’m shure that francescaluce is working on the shader, as usual the time will pay us with a producion quality shader. (both hands cross fingered)


#54

You are correct (as far as I know). If you have more than one shader assigned to different parts of the same mesh, you need to apply a different buffer_store to each part. The only reason this is a problem for you is because you’re using a scene that’s already been created, before the ctrl_buffer shader was invented.

Normally you would plan to use the ctrl_buffer shader right from the start of you scene, so it wouldn’t matter. To help manage your knife scene you could create Quick Select Sets of the different areas that need a different shader, that way you won’t need to reselect the parts manually if you need to change shaders.

For other people out there who may not know, if you want to ‘convert’ a normal shading network (like a phong with textures in a few slots) you don’t need to totally start again using seperate shaders for each frame buffer. You can branch your textures (say one for specular) off into a totally separate Surface Shader and then connect that Surface Shader into the buffer_store. Which means your original shader is unchanged, it just connects out to ‘satellite?’ Surface Shader nodes.

I think I better make some images and a scene! Hehe.

:thumbsup:


#55

Haha, now I’m confusing my own self working on example scenes. Some things I’ve noticed:

  • It seems to crash if you try doing more than one object at a time.

  • If you’re using a bumped shader as a frame buffer, you need to turn on ‘Export with Shading Engine’ on the Shading Group node of the buffer_store otherwise the bump renders crazily (at least with 2D bump). I got the idea from the Misss_simple shaders, you have to do it with them too.

  • The object you’re frame buffering seems to render with no anti-aliasing against other objects, so perhaps hide everything else (at least from primary visibilty).

:shrug:


#56

Jozvex

Maybe you can help me with a simple setup. I don’t know what I’m missing,but I can’t get this simple scene to render out the buffer passes

Sample Scene
Bufers.mb

Thanks

Dan


#57

Daniel Whitton, open the attribute editor for the buffer_write shader and change this “” to this “/”, at the filepath tab. Then it will render just fine:)


#58

@ Jozvex ::. You’re a voice from the heaven. Your reply was very helpfull, very clear indeed.
I’ve run in many crashes too… About the aliasing, i don’t know… I suggest to change the filtering option in the buffer_write node. For the bumb i didn’t try, but the export for the shading engine sometime is exactely the medicine for crazy renders.

@ David ::. I’ll test your scene as soon i can… Thanks for posting.

-elvis


#59

Hey all;

I´m overhelmed of these things, I really want to try that but I can´t download the files, explorer says the .zip is CORRUPT ARGH!

Help me please!

I´ll try to download it at home just to make sure though.


#60

anti-aliasing is not working here too