Cool things in XSI no one knows!


Okay, I don’t know if anyone has tried this but, sometimes I notice my renders getting too slow…so what i do is, for closed objects like buildings and walls (modelled with volume), I plug a Front-Back switch node on the material, and the surface in the front node so that mental ray only renders the faces the camera is looking at. useful if you move your camera back for a tight angle and you notice that the wall is blocking it or you want to specify which surfaces are double sided :slight_smile:

If it seems useless, ignore my post.


I just noticed this… Setting up a toon rendered character. Normally when you clone and scale -x, your render will have a seam along the disconnected center edges. Well, if you set a Seam Group value on the toon material that’s along x axis, voila, no more seam. :slight_smile:


Hey, I just made a great new discovery involving cloth and object constraints…you can create clusters that will be the areas where the buttons will go. I am using FND so the steps may differ if you are using Syflex. This will work on simple cloth objects, but will look awesome as hell if the cloth is super high res.

Here’s how:

  1. Create cloth object as normal…it can be a shirt or whatever.

  2. Then create the objects that will serve as buttons…

  3. Once you have the cloth the way you want…start creating new point clusters(found this works best) on the already calculated cloth and name them appropriately. Like Button 1, Button 2, etc.

  4. Once the cluster is created, select the button object and go to Constrain>Object to Cluster…and select the appropriate cluster. It will snap to that cluster. (Which is why I did not click Cns Comp)

  5. When you play the simulation back the button will follow the cloth’s motion. It will look weird at first as if the object does not follow the orientation of the cloth (depending on how it is animated). To fix that, in the Object to Cluster Constraint PPG, activate both Tangency and Normals.

  6. to further make this interesting,set the buttons as an obstacle. (Don’t know if this will work with RBD’s). Collisions will be an issue but with clever camera work, it will not be too noticeable. You can also use edges for this method too for Zippers.

Hope this works…



Well I bet everyone knows this, but I just read through the topic and didn’t spot it.

If you have a polymesh selected and then use Create > Polymesh > Subdivision it XSI will create a smoothed version of you object that updates as you change the original.

Just move it out of the original polymesh if you are working in shaded or something.


deleted deleted deleted :slight_smile:


I just ripped this off the XSI mailing list:

it seems there’s a little easter egg inside XSI.
To get the list of the XSI team, the people responsible for this great software,
create an empty file called: ShowMeTheTeam.dsc
then in XSI, File>Import>SI 3D Scene/Model and import this file… click OK and
there you go… :slight_smile:

pretty funny I think.


I know this used to work in XSI 3, but I haven’t been able to get it to work since I upgraded to XSI 5.

Did I miss something? Some setting that needs to be toggled or the like?


One of the little buttons that shows up in the viewport enables it (w/o alt).


i always got stuck when i selected the whole time range in the mini dopesheet (shift lmb) because there seemed to be no single click way to deselect the range again.
when selecting only a portion of the timeline you can click in a non selected area to deselect the range. doesnt work obviously when all the time is selected.

now, i finally thought, as xsi is very consistent with its controls and shortcuts, when i can deselect in the viewport with ctrl-shift click, maybe it also works in the timeline… and voila!!

i can just deselect the ranges there as well with ctrl-shift lmb :slight_smile:

maybe it is clear to everyone but i suffered 6 month from that and i am happy that i could solve it :wink:


XSI 4.0 introduced autohide sections to layouts, making areas appear when the mouse entered certain areas. Whilst a very cool feature, it sometimes felt like you were boxing the UI. So this little modification will create a button in the layout that expands or contracts the hidden area.

You will have to edit the xml, adding optionbutton=”container” to either the frameset or switcher tags.

More info and example layout here


Ok, I use XSI since v1, and I never knew this is possible.

you can mark multiple regions in the DopeSheet using <shift> + <Q>…

I guess this is basic, but it’s new to me :scream:


Also, if you hold “L” while in the [M]ove tool, it will temporarily enable welding for as long as you keep it pressed.

And while we’re on that tool, I should point out that J works for the “sliding” option as L does for “welding”. :wink:


I don’t think this one was mentioned before:

The “Page Up” key will bring up the last PPG you’ve had. (Really handy when you just closed it and wanna get back to it quickly.)


if the removal of the “autokey” button in v6 ppgs bothers you? you can, instead of going to the bottom animation toolbar to turn auto key on, just right-click on the top left of the ppg. you can summon the animation editor, interpolation options, along with other keying options, including… autokey!


not brilliant but i find it usefull :wink:

in the explorer you dont have to click on the actualy scroll bar to scroll. You can just click drag anywhere away from an object within to scroll, very handy.


Middle click on render region hides it.middle click again and there it is again.
If you type Make666 in script editor you get little red devil rig.


Draw a render region and then start a capture…works great for low res previews.


When you are saving a image file, for example a render region one, you dont need to select the file type if you already have a file of the type you wish saved in the save folder. Just select that file and change the name of yours. It is easier than to go to drop down list and find and select your file type.


Orrrr just type the extension with the name :slight_smile:

testrender.tif bam!


True! i didnt know that because i had tried it and didnt worked, it defaulted to .pic. Right now i suspect the reason was because my file extension was incorrect.