Control rig size problem ?



I use motion builder since a long time, but I never expected a bug like that.

My control rig generated is really too big !


I don’t want to set up marker by marker manualy, Because everytime I generate a new one, the problem will be the same.

Any idea ?


if you don’t want to scale the rig itself manually then try creating your character geometry and skeleton Larger.

after than you can use the character reference to scale back down to the size you need.


Thanks Bilbob, that’s an idea.

In fact, the same character at the same size have work by the past, it’s just a bug on the last recover version.

I’ve redo an export and a charactérisation after a merge, and it work now.

But strange bug. I can’t understand what is the information take by motion builder to have a ratio / size for le control rig.


Is there really no other way?
I found the same thing and have temporarily solved it the way You mentioned. I scaled up my character 10x.
I don’t like this solution because I’d like to use this along with existing set of characters and rigs I already have set up. Scaling it up and then back down again just doesn’t make me happy.


Well those are the only options i know of… maybe someone else here has more insight than i do.