Connect Edges not Preserving UV's


I ran in to a weird problem today. Searched for an answer but couldn’t find anything.

For the past week or so I’ve been using Connect Edges with a high Pinch value to add edge loops to corner geo that I need to stay sharp after smoothing. This has been great because it doesn’t mess up the texture mapping at all. Until today. Suddenly, whether Preserve UVs is checked or unchecked, no matter where on the mesh I try and connect edges, the mapping gets all screwed up.

I walked down the hall and asked a co-worker to try it on his machine on the same file and his worked just fine.

Has anybody else had this problem? I swear it was working fine on this file as late as yesterday night. The only thing that happened between now and then that I’m aware of was a reboot caused by Windows auto update. I’m totally stumped.


Weird. It didn’t used to work sliding a connect, but it was fixed years ago and that is a recent version of max judging by the fact it has caddies in it.

Although it’s not a solution to the problem, try swiftloop. That’s much quicker as it connects where you click on an edge ring. Not as precise if you want to use the same values again though.


Hey, thanks for the reply robin. I’ll give swiftloop a try. I really do like being able to enter exact values but I’ll just be happy to cut a loop without wrecking the UVs at this point.


You should still be able to use slide and pinch with a UVed model just fine. I can’t think why it doesn’t work in this case. It worked as expected when I tested it.

Turn preserve UVs off in case that’s messing it up. You don’t need it on for that to work in connect.


This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.