commandline render maya 5 and 6


#1

I’ve got maya 5 and 6 installed in my system
however, when i type "render (blablablh) " in commandline, all i can reach is maya 6 renderer.
i find that by changing the enviromental variables in system property: Path from the maya 6 path to maya 5 path, now render will trigger maya 5

since i got a few projects some of them using maya 5 some using maya 6. each time when i render frm comanline i got to change the env variables by hand on EVERY render machine!!!

is there any way to include a command in my .bat so that my env variables can be set from the bat ? or any other method ?

thanks


#2

I don’t have try it with 2 maya installed, but you can try to locate with that :

cls
c:
cd
cd program files\aliaswavefront\maya5.0\bin (your bin directory)
render (your .mb path)
I’m not really aware of that but …


#3

i tried this method b4
, i somehow had it works b4

but now all my new system doesn’t work using this method i dunno why
it will just stick ot the enviromental var path


#4

Just use the full path to the version of maya you want to render to in the batch file.


#5

full path? i tried but full path with switches seems not working, or i cant figure out the syntax
can you write one sample line? thanks


#6

just one hint:

maya 6.0 has a bug in the command line render. the -rd flag is broken and funnily expects the path you write to have forward slashes on windows…

reported and logged

cheers

alexx


#7

Odd, I don’t ever use forward slashes for my rendering from the command line in Maya 6 and it works fine. I use double backslashes though so not sure if that makes a difference.


#8

you use the -renderDirectory flag on a windows machine?
the rest is still backward slashed…
answer from alias about it:

Hello Alex,

I have been able to reproduce the problem and it looks like the -rd flag is broken.

I have logged a bug for you in this regard and it should be resolved in a future update.

Regards,


#9

You have to put the full command and path in quotes since “Program Files” has a space in it (retarded windows).


#10

ya I use the -rd e:\images\renders\ filename.mb and it works like a charm. Or if I’m rendering to another computer at home I’ll use -rd //mycomp//share//images// filename.mb.


#11

bill, good to know that this works…

cheers

alexx


#12

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.