Click on object to rotate in viewport not working?


#1

I have my preference settings set to “Camera mode = Cursor” however when I click on an object in one particular scene, I dont get the yellow cursor that appears on the surface of the object that I clicked on. When I try rotating in the viewport, I dont rotate from the point I just clicked, but from the center of the world axis.

If I open any other scene file I get the correct behavior when navigating the viewport, but not this one particular file.

Any ideas as to what Im doing wrong?


#2

Is the little cross green? Then hit the “Insert”-Key.


#3

No cross. Thats part of the problem. Something is either switched off on that file or the file is buggy.


#4

You’ve probably checked but what have you got set under View/Cameras/Navigation?


#5

this problem created due to wrong setting of navigation button
to fix this issue change navigation setting in camera section on view menu
Here:- Importance of education in our life


#6

@SockGardener I have things set as they should. Navigation works fine in every other file except for the problem file.

@RS727511 I believe you posted the wrong link?

Thanks guys. I feel like I’ve solved this before–but cant quite remember. This search abilities of the new cgtalk are pretty bad so i cant really look back. The old search engine was better–but thats another story.

21