Clamp Constraint not rendering + wrong position



I’m new to Cinema 4D (Education version) and have some difficulties with the constraint expression tag.

The problem is the following: in my scene, three blooming flowers are floating on the water surface. All of them are clamped to it. So I saved the file, opened it again and all I could see was one single flower in the center of the scene. Everything else disappeared. Then, if I clicked randomly somewhere in the view port, all the three flowers would appear again and take correct positions. Animating the scene in the viewport works fine but as soon as I start rendering it in the picture viewer I see that only one flower in the middle of the scene again and nothing else. Can’t really solve this issue. I would be happy if someone could help me out. Thank you!


I have exactly the same problem in my project. I tried for hours to fix it but it doesn’t work. Strange thing that it worked before when i did some test renders with the picture viewer. Also it works in render view, but as soon as i try to export with picture viewer my object is stuck in the middle of the scene. Would really appreciate any help. Thank you!