Cinema 4D EXTREMELY LAGGY


#1

Alright so this issue came out of nowhere and its been impossible to work in c4d ever since.

The viewport is extremely laggy to the point where it moves 1 fps, if I try and add an object it takes it nearly 30 seconds for it to appear in the viewport.

I’ve tried all sorts of ways to fix it but none of them work, I’ve tried disabling OpenGL and disablong enchanced openGL and the problem is still there, I even tried reinstalling cinema4d and the problem wouldn’t go away, one thing I’ve noticed is that after I put my plugins into it, it starts buggin out, I tried taking them out, though the problem remains.

I have lost 3 clients due to this problem and if I don’t fix it soon many more will come.

I work on an iMac, the specs are:

GPU: AMD Radeon R9 M390 graphics processor with 2GB of GDDR5 memory

CPU: 3.2GHz quad‑core Intel Core i5 (Turbo Boost up to 3.6GHz

Memory: 8GB (two 4GB) of 1867MHz DDR3 memory

If anyone could help me resolve the problem I would be forever thankful.


#2

Ok so a couple of things to check here: what version of C4D? Certain versions may have unsquashed bugs. Also, is your graphics driver up to date, as that will most likely affect interactive performance.

Do you have this problem on other applications, for example Blender? Pretty easy to get hold of that and test it out. If it is lagging 8n blender too then it’s a more general issue (OS or drivers) if Blender is fine there’s an issue with your C4D install.


#3

Also try MAXON support if it hurts your business. Usually they are really fast with their replies, in my experience.


#4

Have you been happily working in c4d on the iMac up until now? Because 8GB of RAM is very little. Check Activity Monitor and see where the RAM is being used.


#5

I run cinema 4d R21.027. Thankfully I realized that amd driver updates are not supported on macs for some reason, so I had to update it the other way and the lag stopped, although there is a stutter every now and then