cgMuscle not updating in viewport


#1

Hi!

Im having trouble with ACT cgMuscle in Max8: moving the Proximal and Distal dummys does not interactively change the muscle on the viewports, but when I slide the time slider to a different frame (the object is not animated, Im only changing the time slider) the muscle jumps into the correct position from one end to the other, even if I return to frame 0 the slider the muscle is in correct position, until I move the dummys and then I have to repeat this proces to get the muscle into a correct position.

This problem also ocurs with the cgTubes, they do not follow their parent bones (even in the provided examples) until the viewports are forced to redraw (or the muslces re-calculated by the time shift, I dont now).

The odd thing is that the driven mesh itslef does get updated in the viewports, as I move the bones (or IK handles or whatever is driving the system), so the proces is correctly calculating the deformations, but not updating the display until I change the frame.

Do you think this could be a problem with my version of Max?  Thanks very much for the help.

Rafael Polit
Quito, Ecuador.


#2

Hi

I found this on the TurboSquid support page, hope it helps:

"Q: I can create ACT muscles in the 3ds Max viewports, but when I attach them to other objects, they don’t want to move or deform. What am I doing wrong?

A: This is a common problem for users running 3ds Max in Direct3D mode. Fortunately, there is a simple solution. Do the following: 1. Within 3ds Max, select Customize -> Preferences. 2. Within the pop-up dialog, choose the Viewports tab. 3. Click Configure Driver. 4. Within the Configure Direct3D dialog, make sure that the Use Cached D3DXMeshes checkbox is OFF. 5. Save your settings. At this point, the ACT muscles should deform correctly within the 3ds Max UI."


#3

Hi Piek!

It worked!!! Thanks very, very much… I came here because it is referenced as the official forum for the product, but unfortunately its not very visited. I probably should look to the TurboSquid page more often! :wink:

And I see its your first post! I am always overwhelmed by people that help others with no other mean than the help itself, thanks a lot, truly.

Rafael Polit
Quito, Ecuador.


#4

I’m glad it worked.

Tell you what, if you find a simple way of mirroring muscles we’ll call it quits :o)


#5

OK, Im game… I’ll start working on the script and post my findings, if any. Hope it works.

Rafael Polit
Quiot, Ecuador.


#6

Wow, you can do that? I was only joking, but if you can make such a script I’m sure it’ll be very popular!

Best of luck :o)


#7

OK, I think im ready to post a Beta version of this script, and I would appreciate any feedback whatsoever. Im posting it in a new thread. Hope it is of help, and works as its working with me! :cool:

Rafael Polit
Quito, Ecuador.


#8

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.