Can't get userSetup.py to run at Maya Startup


#1

So, I’ve looked around already. I see that there are many posts scattered about that suggest that userSetup.py is executed so early that you have to use evalDeferred in order for it to run scripts after Maya is idle.

Only problem with that is that I don’t see many good usage examples of how to use evalDeferred in python that properly explain why it is where it is.

I figured that since it is a MEL command that the usual cmds.evalDeferred would apply.

All I am trying to do is get the PIPELINE UI to load on startup instead of having to press a button I made to bring it up. I just want it to be there default everytime.

I tried using generic userSetup.py. Nothing.
I tried adding it to userSetup.mel using the python("import etc…
Which does work. Still would like to get the userSetup.py working for me.


#2

I’m not sure I understand the question, but I just create a function and run it with evalDeferred. It works for me

def runThis():
   print "TEST"

cmds.evalDeferred( runThis ) 

Isn’t something like this enough ?