CAD converting object with a lot of soft curves


#1

So we’re developing a look for the marketing arm of one of our clients. It involves a very reflective dark material, like black onyx, with a lot of subtle curves. Basically a knee implant. For the most part the converter in Cinema does a phenomenal job and, this looks ok for the most part, but there are obvious seams and polygon breaks at certain angles and I’m unsure what to do to fix this. The object is very dense and used the Heal function during conversion. I’m unfamiliar with the Stitch function and wonder if this would be the magic bullet? Does anyone have deeper understanding of the CAD conversion process that can explain what we’re seeing and if there is a workaround to fix the seams. The edges pointed out in the image attached coincides with seams where patches of polygons come together.

Thanks guys!


#2

Could you provide some wireframe close-ups ?
The model was created in C4D right ?


#3

I only see reflections (edges of a rectangle on a curved surface) no breaks or seams … picture is too small and dark to see anything … your cad import seems preaty rough nevertheless hence i can see strong polygonal edges on the arch underneath ( left to the orange background there are only 3 subdivisions to form the overhang ?)

as demis said we need more info … details,

i recently came across “Pixyz” importer which is better than any importer i’ve seen so far. (even Moi 3d) might help you to try it out.


#4

Occasionally I have to retopo problem areas due to the horrible mesh created in the conversion process. If you are lucky you may be able to fix the problem areas with the C4D mesh checker.


#5

Hey, thanks for lending some brain to this, I really appreciate it!

Sorry, I meant to make wireframes.

These are STEP file conversions from a CAD engineer. The model was not created in Cinema, just converted.

I blew out the levels so you can get a better view of the surface reflections along the seams.

Attached my import settings as well.





#6

I’m not sure what this is? What is the mesh checker?


#7

I believe it was introduced in R16 but it can help eliminate complex poles, non-planar poly’s, etc. This video by Digital Meat gives a nice overview.

If it’s an issue with your normals, the Vertex Normal Tool is also very handy.

The new remesher in R23 may also be an option but I’m still on R21 so no first hand experience with that.


#8

That is super cool. I did not know it existed, but someone else here did and has used it a lot on another project. I’ll be using that more for sure from here on.

It has a lot of complex poles, but I don’t think you can get around that with this one. Everything else checked out fine in the mesh checker, unfortunately.


#9

Looking into the vertex normals as well. You might be on to something with that.

We’re still on R21 as well, but that remesher is definitely looking like a good solution if all else fails, it may be time to jump up to R23. Thanks for the tips!


#10

That’s the main issue. Can you get the STEP file? Then you can control the meshing yourself.


#11

That’s exactly what I did. I have the step file. I converted it in C4D using the settings I posted above and the result is the seams and I’m wondering if there settings I can tweak to alleviate those hard edges and seams. 99% of the conversions come across great, its just this particular object with all of the subtle smooth curves that I see the seams and I’m not sure how to fix them or if there is a setting in the conversions that would take care of the seams.

Thanks Mike!


#12

If you could isolate the object you may be able to use the volume builder and mesher to create a new mesh.


#13

Troyan - apologies, should have read the whole thread before jumping in:

I’d second various comments above:

  1. Import settings:
    Normals: The setting you have ‘Phong tag edge breaks’ will create phong tag edge breaks - and approximate shading in those areas I believe. I suspect this might be the issue. I’d try this set to ‘Normal tag’.

If that doesn’t fix it…

  1. Save your file, then delete all normal tags and add a standard C4D phong tag in place - with appropriate angle limit etc. Does that help?

If that doesn’t fix it…

  1. Modelling > Mesh checker: any naked edged etc?
    … if so, At this point I’d try ‘stitch’ on import. However that does involve moving vertices to weld them together, so it does modify your geometry. I might start with a value of “1” here. Value is ‘number of passes’ of the stitch function.

  2. Import via another converter - do you have MOI3D ?

Modelling > Mesh checker


#14

@LonChaney

That is a route to explore but I’d be leary to go that route being the nature of volumebuilder can be a bit loose sometimes and the engineers can get really picky on details of the design. If I can’t get a good workflow converting a CAD file that will be the next step. I’d just like to exhaust all avenues with straight conversions for similar future situations if possible.

Again, thanks for adding some brain to this :).


#15

Thanks Mike

  1. I’ll try that. Traditionally I find I get better results using Phong Tag Edge Breaks over the Normal Tag. For some reason, the Normal Tag option tends to create random bad looking geometry in spots on the object where Phong looks much smoother.

  2. I’ll try that next

  3. I did run it through the mesh checker and it gave it a clean pass except for a large amount of complex poles, which I think it needs.

  4. Have not tried it with anything else yet, I’ve used MOI in the past and it’s a great little piece of software. I’ll run it through if everything else fails :slight_smile:

Thanks Mike!


#16

Troyan,
Just one other thing worth checking that might be a simple solution: Just do a:
Mesh > Normals > Select Broken Phong Edges
and then:
Mesh > Normals > Unbreak Phong Edges

Just in case there are inappropriate phong breaks in the mesh.


#17

Ok, so I tried reimporting using Stitch set to 1 and Normal Tag instead of PHong Tag Edge breaks and it was a big improvement. Still some hint of seams here and there but I’ll but it can be tweaked with the help of the mesh checker.

Levels are blown to exaggerate seams.

More playing coming



#18

Thanks Mike!

That did not seem to make a difference, but something to keep in mind on other CADs.


#19

Keep in mind, not all CAD is created equally. Sometimes the creator will have just flat out taken shortcuts and the problems you see in the model are inherently there, no amount of setting adjustments will get rid of every kink in the model.

Things to try:

Delete the normal tag, this does make it worse more often than better but sometimes c4ds generated normals will beat the embedded surface data

Select all points and run the optimise command with varying tolerances

When importing, dont activate the max length option that adds a polygon every 1mm or so, instead try lowering the tesselation > detailing > sag value to 0.02 or 0.01 to add extra geometry to the soft curves instead.

Worst cases I turn off all phong and normal tags and just import with a super dense mesh. technically it is all facetted but enough polygons will hide this fact.


#20

That’s a good point. I think if this accelerates we’ll probably wind up working directly with the engineer to see what we can do to create the cleanest mesh possible.

I have not done that yet, I meant to. Thanks for the tip.

Now that’s interesting. I’ll give that a try next and see what happens, I wasn’t aware of that approach.

Wow, so no smoothing at all. Interesting. I’ll give that a try also.

Thanks for the braining Mash!