C4D's lack of multiple phong tags - workarounds?


#1

C4d to my knowledge only supports one phong tag per object. This can be problematic, esp. when working w/external programs.

As I understand Maya has something called smoothing groups, which I suppose are essentially the same thing. But you can have more than one.

Anyone know of workarounds?


#2

In edge mode, make your selection where you want seams in the shading and use “Mesh>Normals>Break Phong Shading”. Play around with this. (Make sure “Use Edge Breaks” is checked in your Phong Tag.)


#3

thanks mmd…the problem doesn’t appear within c4d…

And my Phong tag was set up with all the breaks so that it looks great inside c4d.

It’s when I export out to FBX and pull into other apps like SPainter. I get good results with OBJ but something is getting lost in translation with FBX.

In googling about I see a lot of users are having problems exporting out into game engines and other apps. It seems to me Maxon needs to address how their proprietary phong approach plays w/the rest of the world.

It seems to manifest itself most with low poly assets.

I hope maxon pays some attention to this and while at it…gives us multiple smoothing groups/phong tags.


#4

Just check the normal flag, when exporting an fbx out of C4D and everything should be fine.

And if you are working with low-poly models, check out the vertex normal plugin and how to utilize that workflow in lowpoly modelling.


#5

Yes I purchased Vertex Normal Tool last month and have been using. But I concede I still need to study docs. Maybe I missed something.

I checked the normal flag. I ran out about a dozen tests and never got FBX working. OBJ worked fine first time.