C4D Through firewall issue


#1

I’m trying to allow C4D through the Windows 10 Firewall. No matter what I try, the firewall keeps blocking it.
I have tried the following options:

  1. Allow an App Through Firewall (from Windows Security — Changed settings / allow another app / path to C4D, checked Private and Public)
  2. From Windows Defender Firewall / Advanced Settings: I have created two rules, both for Inbound and Outbound, in advanced I added Domain, Private, and Public

I’m running out of ideas. Any suggestion?


#2

Anyone?
I don’t want to leave the Windows firewall off, I think it does a good job.
But I need Cinema to get through with XP authentication and all.


#3

I don’t know if this will help you at all but I’ll share.

The last time I had difficulty with my firewall it turned out not to be my PC’s settings but the firewall on my router.


#4

Thank you @IceCaveMan

I’ll check the router.


#5

I actually figured it out with some help from a Windows 10 forum. I’ll post the solution here just in case someone else is having the same issue.

I’m using Malwarebytes Windows Firewall. I didn’t notice there’s an icon to view the connections log, which is very handy. It turns out there are other connections running on top of the exe I white listed in the Firewall. After I unblocked one of those extra services Cinema could finally get through the firewall.