C4D + Redshift = unusable?


I haven’t posted here in ages. Oh boy if my profile picture is old!

Anyway. The latest experience with C4D urged me to ask here if I’m an isolated case.

The last release I’ve used on my old Threadripper 1950x with a dual 1080ti until last year was C4D R21, with Redshift v3.0.65, .
The result was a frustrating experience. C4D would crash basically at every session. Redshift was feeling extremely delicate, something sometimes you could break by simply moving the render window.

I lately moved to a new PC, an i9-13900KF, with a dual 3080ti. I’m on C4D 2023 + Redshift v3.5.12, and sadly, the situation hasn’t changed. Every time I close C4D, there’s a crash caused by Redshift, which I wouldn’t particularly mind, except for the fact that C4D freezes for a while, and so it does when I open it again.
The problem is, it also crashes while I’m working, which makes it basically unusable.

The projects I work on aren’t too heavy, or complex. I even started using 2k textures to limit the burden on the VRAM.

Even though I don’t consider a dual 3080ti on par of, say, a 4090, still the projects are typical motion graphics stuff that my old Threadripper should already be able to handle.

It seems to me that something is off. Somewhere between Maxon, and Redshift things went wrong in terms of software stability, and it’s now out of control. But perhaps I’m just one of a few cases?
That’s what I asked myself, until I started noticing the same issue in at least three different companies I worked for in the past year. Same type of bug, same crashes, same stability issue.

What’s going on?


The versions 2.5 XX were stable enough, RS had one platform: Cuda on Windows It had it’s own quirky logic but it worked.
Maxon acquired RS, now they have to develop for Macs, Radeon, M1 . . . The nimble race car feels as if it turned into a bus.
3. XX releases have their share of bugs but it is stable enough IF you remain abreast of the latest quirkiness . . . .

Definitely usable but can be infuriating at times.


FOCUS on art. Not on hardware. Fill your portfolio with images. Where is your art?


That feels a bit condescending.


Thanks @laurent

Yes, I remember the 2.5x being definitely more stable.
Maybe I can roll back to an older version, and see if it gets better, although with the 3.x series I didn’t have much luck.


A forum is a place where people can ask for help.
If you are curious about what I do, here: https://phoenixart.com


Depending on your HW config (and your use of in-render denoisers) you might have better luck with the “magic” nvidia drivers. The last stable version is 497.29. Probably worth a go if you’re having a lot of crashes.


Ok no problem. @phoenixart
I meant you did not have a single art in cgsociety portfolio.

It is mostly about optimising the scene you are working with.


Thanks @danielHinton I can give it a try.

Was there a point when Nvidia driver got some RTX optimization? I seem to remember prior to a certain release, RTX wasn’t optimized, but I might be confusing things.


Yes, but I don’t recall the driver (and in my case with my measly 1070s it was irrelevant anyway). That driver I mentioned should help with VRAM sharing between GPU-hungry apps and Redshift, so if that’s the cause of your instability then happy days.


I can tell you the only frustrating thing with c4D and Redshift right now is the problems launching an Adobe program creates. There’s a technical explanation but it is very frustrating nonetheless. Any Adobe product will slow Redshift to a crawl and sometimes cause a crash, but otherwise, seems pretty rock solid. Not seeing the issues you are. I’m running just an i9 Intel with a 4090 RTX card. Our crew here has a myriad of PC and Macs and noone seems to be running into any of the issues you’re experiencing.


I’m glad that is working for you, but unfortunately, that is not my experience at all.
I’ve been using C4D for 20 years, never had so many issues. It worked great up to Redshift 2.6.xx.

Again, this is not an isolated problem. I’m seeing the same crashes happening on different configurations. I submit the crash every time. I will try to reach out to Maxon directly, but I don’t hold my breath: these errors have been around for quite some time.

Even on the Redshift forum I remember a while back people reporting crashes when simply moving the RS RenderView window.


So Redshift is unstable with your setup? I have no experience with Redshift but I have tried demo version. It works well with Ryzen 9 and with Nvidia graphics card. I see this as technical incompability issue.