bumpcombiner 1.3b not compatible with maya 6.4 or mentalray 3.4


#1

bumpcombiner 1.3b not compatible with maya 6.4 or mentalray 3.4

so mr fails while rendering after installed this plugin.

any newer one for maya6.5 ?

or it comes with a different name with maya6.5 in mentalray shaders?


#2

Hi, you ca try to use the bumpConnector::
http://www.dirtycraft.com/shaders.html

this is a really simple shader, it work with the uv map coords.
I will made a new and more featured version as soon as possible.

Alessandro


#3

bump connector is also not compatible with maya6.5

are you sure ? ever you tried ?

however thanks.


#4

Yes the bumpConnector is compatible with maya 6.5 and MR 3.4, I know because I made it.
It’s not a c++ shader but only a MR Phenomenon :wink:

Alessandro


#5

[size=2]I dont think so…[/size]

phenomenons can be incompatible too.

[size=2]da daaamm…
after installed.
// Info (Mayatomr): Aborted //

no any mr renders works after bumpcombiner installed.
(my old scenes without bumpcombiner fails mr rendering)

I am deleting this shader from rayrc. and deleting its files…
than everything goes normally.!!!

[/size]

do you have a sample scene ?
after my mentalray says “aborted//”.
no any other mental renders works. after I try to render a scene including
this shader


#6

I use the bumpCombiner v1.3 in maya 6.5 without problems and the bumpConnector without problems
this is my maya.rayrc file

#*****************************************************************************

Copyright 1986-2003 by mental images GmbH & Co.KG, Fasanenstr. 81, D-10623

Berlin, Germany. All rights reserved.

#*****************************************************************************

Evaluated at startup time of the plug-in to fill the mental ray registry.

#*****************************************************************************/

registry “{MAYABASE}” value “C:/Programmi/Alias/Maya6.5/mentalray” end registry

registry “{SYSTEM}” value “windows” end registry
registry “{DSO}” value “dll” end registry

$lookup “{MAYABASE}”
$lookup “{SYSTEM}”
$lookup “{DSO}”

registry “{MRMAYA_START}”
link “{MAYABASE}/lib/base.{DSO}”
link “{MAYABASE}/lib/physics.{DSO}”
link “{MAYABASE}/lib/mayabase.{DSO}”
link “{MAYABASE}/lib/contour.{DSO}”
link “{MAYABASE}/lib/subsurface.{DSO}”
link “{MAYABASE}/lib/mi_openexr.{DSO}”
link “{MAYABASE}/lib/bumpCombiner.{DSO}”
mi “{MAYABASE}/include/bumpConnector.mi”
mi “{MAYABASE}/include/DGS_Bumped.mi”
mi “{MAYABASE}/include/prova.mi”
mi “{MAYABASE}/include/pUtility.mi”
mi “{MAYABASE}/include/usefulPhenDGS.mi”
mi “{MAYABASE}/include/mayabase.mi”
mi “{MAYABASE}/include/base.mi”
mi “{MAYABASE}/include/physics.mi”
mi “{MAYABASE}/include/contour.mi”
mi “{MAYABASE}/include/subsurface.mi”
mi “{MAYABASE}/include/bumpCombiner.mi”
echo “mental ray for Maya - startup done”
end registry

$lookup “{MRMAYA_START}”

NOTE::
the bumpConnectro declaration need to be write first in the .mi file declaration.


#7

it is the trick to write at first in mi linking lines…
hmm…

Thanks :thumbsup:


#8

Just for the records:
BumpCombiner (1.3b) works like a charm with maya 6.5/mr 3.4.

Maybe you messed up your rayrc, butcherhell?


#9

if I add bumbcombiner… MR fails.
if I delete my own added red lines from rayrc; everything goes okay
so here is my rayrc… (with RED lines ;fails… without’em all works)

what is still my problem ? order of registering lines ?

thanks

registry “{MAYABASE}” value “C:/Program Files/Alias/Maya6.5/mentalray” end registry

registry “{SYSTEM}” value “windows” end registry
registry “{DSO}” value “dll” end registry

$lookup “{MAYABASE}”
$lookup “{SYSTEM}”
$lookup “{DSO}”

registry “{MRMAYA_START}”
link “{MAYABASE}/lib/base.{DSO}”
link “{MAYABASE}/lib/physics.{DSO}”
link “{MAYABASE}/lib/mayabase.{DSO}”
link “{MAYABASE}/lib/contour.{DSO}”
link “{MAYABASE}/lib/subsurface.{DSO}”
link “{MAYABASE}/lib/mi_openexr.{DSO}”
link “{MAYABASE}/lib/mix8layer.{DSO}”
link “{MAYABASE}/lib/bumpCombiner.{DSO}”
mi “{MAYABASE}/include/bumpConnector.mi”
mi “{MAYABASE}/include/mayabase.mi”
mi “{MAYABASE}/include/base.mi”
mi “{MAYABASE}/include/physics.mi”
mi “{MAYABASE}/include/contour.mi”
mi “{MAYABASE}/include/subsurface.mi”
mi “{MAYABASE}/include/mix8layer.mi”
mi “{MAYABASE}/bumpCombiner.mi”
echo “mental ray for Maya - startup done”
end registry
$lookup “{MRMAYA_START}”


#10

I don’t know, but are you sure to have copied the files in the correct folders?

Try to move the bumpCombiner lines before the mix8layer in the maya.rayrc


#11

You forgot the ‘/include/’ before the bumpCombiner.mi declaration. As I said some days before: Never! rely! on! readme! declarations!

It’s mistyped by francesca, errare humanum est, ladies and gentlemen. Quot erat demonstrandum.

PS: Hell, I’m such a wisenheimer. :cool:


#12

eheheh, good job floze :slight_smile:


#13

aagrrhh.h… !

how I not see thaDd…

sorry for wasting yer times…

big thanks… I should see something wrong with me :smiley:


#14

pantich78 your shader is cool, but I can´t find a way to use procedural textures with it, it only accepts filenames, like “name.jpg” or something like that, I tested it and I love it, is there a way to use also procedural textures like “checker” or “ramps”?

Thank´s in advance. vbmenu_register(“postmenu_2173463”, true);


#15

Hi Joie, thanks.
Now my shader accept only file textures and not procedural textures.
May be in the future I will update the shader, but now I have no time for do that, sorry.

Bye,
Alessandro


#16

I always copy/past from the readme coming with francesca’s shaders and they work fine. I just copy past in the bottom of my rayrc before the line:
echo “mental ray for Maya - startup done”


#17

Does the bumpConnector work with Maya 7.0?


#18

yes it’s working ok :slight_smile:

since you asked in another thread how to use it, here is an example on how to add bump to an dgs_material:

  1. create a dgs_material and a bumpCombiner node
  2. in the hypershade plug the dgs_material.outValue in the bumpCombiner.m_input
  3. On the bumpCombiner AttributeEditor: Check the “Enable Bump” checkbox, then click on the ::bump.base mapButton and from the Utilities tab choose bump2d
  4. finaly plug your texture in the bump2d.value slot

#19

Thanks so much yashu!


#20

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.