Bug with Random Modes 'Noise' & 'Turbulence'


#1

Not sure if this is a feature or a bug, but in this particular scenario, the Random modes “Turbulence” and “Noise” only seem to displace matrices along two axis (slightly along the third, but very little).

The spline is just used for the demo scene - the effect is still seen when the Matrix is switched to Linear mode rather than Object.

Thoughts?

Scene File


#2

Try checking Indexed in Randomize/Effector


#3

It’s the transform space. If you change it to “Object” it will work as you desire.

As it is…the noise on the one axis is translating along the circle, rather than extending out from it.


#4

Thanks for the ideas!

  • Adjusting the transform space doesn’t fix it; it just flips the axis. Leaning out on the top instead of leaning in (as seen in the initial image).

  • Checking “Indexed” appears to fix it, but the noise pattern repeats quite strongly, even when the scale is large (this is at 1,000):


#5

Maybe we aren’t talking about the same thing.

When I changed the Transform Space in Randomize:Paramater from NODE to OBJECT…the Circle’s Points displace in all 3 dimensions.

I could verify that by alternatively zeroing out the X,Y,Z positional offsets.

In contrast with the Transform Space set to NODE… the Z translation was traveling along the circle and thus didn’t appear to be doing anything.

If you isolate them by zeroing out all but X, then all but Y, then all but Z…you’ll see.


#6

I also experienced this behaviour for a long time. Only workaround I know of is to use different effectors with different scale settings for every axis


#7

Matrix object switched to Linear & Randomize Parameter --> Transform Space from Node to Object. Still doesn’t work correctly.

I can adjust each parameter individually, but when they’re all enabled it only works like this.



#8

Hi,
this might be a limitation. Since all matrices are sampled at the same time for all applied parameters, there’s probably a method for “randomizing” the results of each parameter which isn’t random enough.

Maybe it helps to break-down each parameter in separate effectors, that way they will sample a different coordinate of the noise for each effector
Letellier_C4D_Random_Noise_SeparateAxis.c4d (155.9 KB)