break/split edges (geometry)?


#1

Hey everyone,

Am I missing something, or there’s no way to break the edges in C4D?
For example I want to break those edges:

So the middle point would split into two points:

Right now I’m doing that in a very weird way via disconnecting faces and welding back some points or through bevelling faces, welding some points and deleting beveled faces. Both ways seem retarded.
Any suggestions are appreciated!


#2

You’re disconnecting in the wrong mode… you need to be in point mode to disconnect a point;)

-kvb


#3

I’ve tried to Disconnect in point mode, but nothing happens (I’m using R16)
Am I using the wrong Disconnect? Wrong point mode? %)
(number of selected points remains the same)


#4

Hmmm, this is quite odd. Worked before when I made my first post, now it refuses to work. Off to submit a bug report I guess… :hmm:

It did seem a bit inconsistent when I tried it before, but I chalked that up to me missing the command when I clicked. Subsequent undo’s (while checking to see if the disconnect was indeed undone) followed by disconnects all worked… until I restarted that is :hmm:

-kvb


#5

Btw, Help states that Disconnect works with polys, not edges/points. If it works on points sometimes that’s must a bug :slight_smile:
Still looking for a solution though!

update:
found similar post on c4d cafe http://www.c4dcafe.com/ipb/topic/84883-disconnect-edges/
It seems C4D lacks this functionality (which is sad)
there’s a script in this post, but unfortunately it only can cut geometry to separate pieces


#6

Yeah, I noticed that too, but it’s listed as a valid tool in points mode, and Maxon has historically been very good about hiding commands that don’t work in certain modes in the tool popup menu. That tells me the command is intended to work in points mode, but for some reason they decided to leave it broken and just correct the help docs… or it’s just poorly implemented in general.

-kvb


#7

Ok, so my last post was more or less me thinking out loud, but I think I’m actually on to something here. I believe the disconnect tool really is intended to be used on points as well as polygons.

I was thinking maybe my earlier success was based on having a polygon selected and running the command, even when not in polygon mode. Maybe discconnect isn’t so much “mode dependent” as other tools (despite not working on points or edges), that it simply used whatever polygon selection was active (no matter what mode you’re in) and running it on that selection regardless of the currently active element mode.

Turns out I’m right! However, the plot thickens;) If you don’t have any points selected the disconnect tool is grayed out in point mode, meaning that it is (or was) indeed intended to work in points mode, on points. There would be absolutely no valid reason to deactivate the command based a on a selection of a type that’s not supported by the tool. If it was all about poly’s and could be fired in any element mode, then it shouldn’t care about any other selection type except for polygons;)

So I think I have it spot on: the disconnect tool is (or was, at one point in time) intended to also be used in point mode, on points, but this functionality is broken and the help docs have been edited to omit this and instead proclaim that it’s only intended to work on polygons… or they just did a poor job cleaning up after their attempt to make it work on points;)

-kvb


#8

Oh man, detective story! Thanks for explanations, I hope that’ll be fixed someday


#9

According to the C4D Help the Disconnect tool can ONLY be applied to polygons and Splines. Nothing else.
If there’s a bug, it’s that it shows as active in point and edge mode, but it’s not supposed to work in those modes anywhere, that’s why it’s a bit confusing.
The workflow to achieve what you want is the following:
Disconnect the polygons containing the points you want disconnected.
Then, select the points you want to re-connect using the Rectangle selection tool, but be very careful not to select the points on the other side of your geometry.
With the correct points selected, right click and “Optimize”. That will optimize the selected points ONLY and since they’re in the same position, they will be re-welded.
I know this is not the easiest way, but with a few more clicks it gives you the expected result.

Hope this helps


#10

Tried disconnect in Points mode in R16 on a simple cube vertex and it didn’t work. However, in R13 it works without problems.

I see no reason why it shouldn’t work in points mode and am not sure why they have changed that.


#11

Sometimes can be useful workflow with sliding edge with zero offset in clone mode.(esspecially in R16)

link to video… http://screenpresso.com/=w4eXf

(would be nice to have script for that maybe…)

Lubo


#12

Thanks for the confirmation Samir:)

-kvb


#13

C4D needs to know which neighboring polys are to remain connected to a disconnected point.


#14

Okay, here’s a script for disconnecting selected points from selected neighboring polys.

Disconnect_Points.zip


#15

You can try my ‘Split Edges’ script. Find it here http://yuraizmailov.tumblr.com/


#16

Hello Yura!
Thanks for providing that script!
The dropbox link provided on your homepage is dead, though - could you please re-upload the script, please?
Thanks a lot!!
Best
Eugen