Book Generator


#1

Hello,
I’m using R19 Studio and am attempting to implement the Book Generator from the Content Browser. I’ve viewed several online tutorials regarding how to use it and followed the tutorial instructions. But to no avail.

Any suggestions regarding how to use it successfully?

Thanks!


#2

Hey there
Here’s a very quick and dirty set of instructions to get you going:

  1. Create a plane Width 50cm Height 20cm Width and Height Segments 1 (you don’t have to get these dimensions it’s just an example)
  2. Make editable by pressing c
  3. Drag the book generator in the scene
  4. Select the polygon you created
  5. (With the polygon selected) click on Add selection as one group. This is in the book generator HUD on the viewport.
  6. Start modifying in the attribute manager

Hope that gets you started


#3

Thanks for your reply!

I’ve been attempting to do this while following these steps several times with no luck.

You suggested to “drag the book generator in the scene.” I assume you were suggesting to open it from the Content Browser and it then automatically opens in the viewport, which it did.

Then, after I followed the steps you mention, I clicked on “Add selections as one group.” But, nothing happens. I feel as if I’m leaving out an important step, but don’t know what it is.

Any other suggestions?

Thanks again!


#4

Make sure you have a selected polygon, otherwise the tool doesn’t know what object to use in order to apply the books.
So select a polygon and then hit that command.


#5

After several attempts with my newly installed and updated R19 Studio, I was having no luck.

Then, I remembered that I still had a copy of R17 Studio on my machine. So, I attempted the same thing in the copy of R17 and it worked just fine.

I went back to R19 Studio. The original download was version 19.008. The update notice that I updated it to was 19.053.

I contacted Maxon and told them about the problem. They suggested trashing the installed and updated version of R19 and doing a reinstall. When I did the fresh install and tested it with the 19.008 version it worked just fine. But, when I updated it to 19.053, the problem started all over again.

Maxon sent me another interim update to try - 19.024. When I tested that update, the problem reappeared again.

So, it appears to possibly be a bug in these updates. Any one else having a problem with this in these updates?

Thanks!