Blender 2.5 Alpha won't Import .obj


#1

Hi, today I am trying to import a .obj file into Blender 2.5 but it will not import it. The .obj is low poly (maybe 200 polys) I opened it in 2.49 and in the test build of 2.5 but it won’t open in the Blender Alpha 0 (mac). Anyone else having problems importing .obj files into Blender 2.5 Alpha 0?


#2

Alpha means it is feature incomplete. So expect things missing.


#3

Yes, I understand but how come I can import some .obj files and not others?


#4

perhaps because the import script is incomplete, and some models use different aspects of the obj file format than others.

I had the same problem, trying to import a 3DS Max model be exporting it as .3ds and .obj, both failed. Then I tried collada .dae, and it worked pretty good, though I had to realign most of the objects.
Remember, 2.50 a0 isn’t for production - make your import via 2.49, save as .blend, then open in 2.50 for testing and playing.


#5

Never thought of that Wayne. Good idea. It’s just weird because I could open the same .obj file in the 2.5 test build from graphicall.org. Not complaining though 2.5 is very sweeeeet! in spite of some minor bugs. Thanks.


#6

it’s possible the graphicall builds were just using the old standard list of scripts and existing files. You’ll notice now that the import ability is much lower, at least in the win64 version I’ve got.


#7

if you’ve got OBJs that won’t import (and can make them public), please post it as a bug on the bug tracker.


#8

broken, I submitted 2 .obj’s, one created by me from 3DS Max, one I got from the3dstudio.com (a while ago), most likely created with Max.


#9

Am also got the same problem. So I feel its better to wait till 2.6. For production purpose I am using 2.49, and for learning 2.5 alpha is good…


#10

This thread has been automatically closed as it remained inactive for 12 months. If you wish to continue the discussion, please create a new thread in the appropriate forum.