Bizarre grain


#1

Working on a shot and using Phys to render. Lighting and reflections are HDR and using Indirect Illumination instead of GI. Getting an odd thing where the entire object is using the same reflective metal but parts of it have 0 grain while other parts have a ridiculous amount of grain. Easily fixed in post but I’d like to know why this is even happening. Even bumped up the blur samples since the reflective metal has blurring. Rounded edges of the gears close to the camera has 0 grain while the engine block and flat front faces of the gears have crazy grain. Any insight is greatly appreciated.

EDIT: Had to pull the video down guys, sorry. The boss doesn’t trust you guys as much as I do ;).


#2

Are you using an HDR with smaller bery bright spots in it? If so lowering the HDR Threshold in Physical Render settings can help. Alternatively you can also clamp the HDR itself.

Either way these super bright HDR spots can introduce a lot of grain.


#3

There are some bright spots, but why is the grain only on the engine and the flat parts of the gears and not over all of the metal parts?


#4

Hi,

Your statement ‘Lighting and reflections are HDR and using Indirect Illumination instead of GI’ is a bit confusing, as Indirect Illumination is just another term for Global Illumination, or more specifically the natural effect the various GI methods are trying to simulate.

So I am not sure if there is a basic misunderstanding, but apart from that your example does not look very uncommon. The grain happens in the expected areas and is caused by the unified subsampling routine of the physical renderer. That effect also happens for the other renderers. The Anti-Aliasing/Sub-Sampling is getting more difficult as more effects are being layered on top of each other. DOF, Area Shadows, Blurry Reflections/Refractions and AA are all sampling based and demand exponential computing times if layered on top of each other.

You can observe that effect by rendering a reflective sphere with blurry reflections and very ‘noisy’ bumpmap. Even when you set the bump strength to a value so that it has no or almost no visual contribution to the image, the result will be more grainy than without any bump mapping.

To counter that effect you have either to turn down the number of layered effects or drastically increase the Anti-Aliasing. Also turning down the the number of samples for each effect (except from AA) can help. For the Physical Renderer you should increase the Sampling Subdivisions as far as you can afford while lowering the shadow, blurriness and sss subdivs as low as possible (You could of course increase both, but then the render times will explode).


#5

Instead of using the GI setting in the render settings and messing with QMC and all that crap along with the Phys Renderer, I’m using the Indirect Illumination setting inside of the Phys Renderer as that tends to create less problems (or no problems, really) with flickering than using the old GI. As far as I’m concerned, they are not the same.

Yes, increasing the sampling would fix this. What AA are you talking about in the Phys renderer? The SSS is at 0. I’d just like to know why there would there be intense grain on some parts and 0 grain on others? Makes no sense.


#6

It’s just confusion over terminology; the old GI effect and physical render’s indirect illumination are both forms of global illumination.


#7

Are you using the default “low” sampling quality?

Looks like grain increases on objects in distance that are most affected by DOF.


#8

No, that’s medium but even at high there’s an unexpected amount of grain. But what I’m trying to get to is why is there no grain at all on the curved surfaces but crazy grain on the flat surfaces near the camera and all over the engine block in the distance? Shouldn’t there be grain everywhere?


#9

I think littledevil is correct in saying that a lot of it has to do with insufficient samples for the DOF effect. I’d try eliminating the DOF and see if that improves things.


#10

it is hard ot be sure, my guess is also DOf as the front objects do seem to have more as well, not as severe but more noise all the same.

Best is to first turn off effects like motion blur, dof and blurry reflections, and then turn then on one by one and see when it gets introduceed.


#11

I’m going with the DOF on this one as well.

You likely do not have the sampling subdivisions set high enough. (initial scene sampling)
This one has the most effect on DOF and MB effects.
Also, I would avoid the indirect illumination check box in the physical settings.
It is the same as QMC but has less control over the sampling.


#12

Here it is with no DOF. Same issue. Setting the blurry reflection samples higher does help reduce the grain, but again, why would there be absolutely no grain at all on some parts and silly amount of grain on others? Same texture, reflecting the same environment, same everything. Shouldn’t there be uniform grain across everything, especially surfaces that are right next to each other?

EDIT: had to pull this also :stuck_out_tongue:


#13

what are you using for environment (images)? All the smooth reflections you have pointed out are curved and perpendicular to the axis of the machine (and at a high angle to the camera). All the grainy areas are closer to pointing at the camera and all are smoother on the bottom than on the top - it looks like you have an image with those qualities being reflected or it’s something to do with fresnel


#14

noticed the same thing BDjones, the flat front facing surfaces are what is more grainy. Personally my guess is actually the direct illumination. There’s obviously a fresnel, so perpendicular faces are more reflective and thus may reduce or cancel out the sample from indirect illumination for simply reflective samples. But for front facing surfaces where there is less reflection, more diffuse contribution is seen and that is being illuminated by indirect illumination and clearly doesn’t have enough samples.


#15

There is no fresnel. The scene setup is actually quite simple. I can’t post the actual map since it’s a purchased map (and it’s huge) but I’ll post a low res or screenshot tomorrow. There isn’t any grain in it. The metal texture simply has reflection with some blurring and specularity set to metal. That’s it. I tried it with another reflectivity HDR and although there is less grain, there’s still a considerable amount of grain in the flat surfaces and none in the curved. I’ll try rendering a reflective sphere and cube in that scene also tomorrow. Phys settings are the preset Medium, although turning it on High helps but it’s not nearly as clean as I’d expect.

Thanks for the insights!


#16

if you could replace the geo with simpler cylinders or something so we could look at it maybe we’ could see whats going on. Obviously not the hdri, you say it’s doing it with other maps anyways right.


#17

Yeah, I’ll do that tomorrow. It would be strange if it had something to do with this geometry.


#18

Could possibly be a funky normal tag?
Were the gears imported form a CAD app?


#19

When a surface is curved, the curvature causes that part of the object to receive light and reflections from a large portion of the surrounding image. When a surface is flat, it is picking out a very small part of the sky object to base its illumination off of, this is likely what is causing your grain imho.

Seeing as the entire object is the same blurred metal texture though, you can potentially save a helluva lot of render time in this animation. Now this will depend on what else might have to happen in the project, but if it were me…:

Disable GI / indirect illumination, its adding very little to the scene. On that object, 80% of what youre looking at is just reflections on the surface, throw in a pair of large area lights and its going to make very little difference to the visual image but will save you a ton of render time.

Next, open your hdri in photoshop and blur the living crap out of it, and save it as a new version. Instead of using blurred reflections in the render engine (sloooooooooooow) just pre-blur the reflective image and use that as the sky (faaaaaast) Use a second crisp copy of the image as the background in the render.

Thirdly, this model would take post-DOF very nicely. Just add a depth map and blur it in photoshop/AE afterwards.

If you do the first two, your render times will plummet, if you do the third too, your render time will probably be 1/100th of the original, and youll be grain-free.


#20

Why do you use GI when you’re objects seem to be 100% reflective?
GI contributes to the diffuse component of a surface,
the reflective one is untouched.